Page MenuHome

Normalize/anti-aliasing bug
Closed, InvalidPublic

Description

System Information
windows7 64
ASUS ATI Radeon HD6870

Blender Version
Broken: (All)
Worked: (None)

Short description of error


{F224561}0


Exact steps for others to reproduce the error
open this file and repeat my test
working with bug{F224567}

open this file, repeat my test
working properly(i don't know why)

Details

Type
Bug

Event Timeline

Alexey (Inwader77) set Type to Bug.
Alexey (Inwader77) created this task.
Alexey (Inwader77) raised the priority of this task from to Needs Triage by Developer.

The default antialiasing filter (Mitchell-Netravali) has negative lobes, meaning it produces sharpened edges.
While these edges look sharper, it can create pixel values outside the range of the original image.

Try setting the antialiasing filter to something else. I believe Catmull-Rom also has negative lobes, but everything
else should be fine.

Alexey (Inwader77) added a comment.EditedAug 16 2015, 10:36 AM

The default antialiasing filter (Mitchell-Netravali) has negative lobes, meaning it produces sharpened edges.
While these edges look sharper, it can create pixel values outside the range of the original image.
Try setting the antialiasing filter to something else. I believe Catmull-Rom also has negative lobes, but everything
else should be fine.

Yes, this bug is active only in mitchel nethravali and catmull rom. but i was not find in my picture colors out of range(0:1)

only if i use black (0.1;0.1;0.1) and white (0.9;0.9;0.9) i can receive full white and full black in border region. All results of anti-aliasing was clamp to (0;1) range

Sergey Sharybin (sergey) closed this task as Invalid.
Sergey Sharybin (sergey) claimed this task.

This could potentially happen with any filter depending on particular texture configuration you're using. This is because of color "bleed" across the edge affecting on mix/max range of the color.

Thanks for the report, but it's not a bug.