Page MenuHome

metric units not persistent
Closed, InvalidPublic

Description

System Information
Operating system and graphics card

Blender Version
Broken: 2.75
Worked: (optional)

Short description of error
units are mixed together instead of showing persistent values, so instead of showing 10mm as 10mm it will switch to 1cm. this is very confusing and leads to a lot of mistakes

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

  1. switch to metric
  2. scale the default cube till you get to a border value like 10 or 100 and see how the units change when you increase/decrease the value.

Details

Type
Bug

Event Timeline

dan grauer (kromar) set Type to Bug.
dan grauer (kromar) created this task.
dan grauer (kromar) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) closed this task as Invalid.
Bastien Montagne (mont29) claimed this task.

Thanks for the report, but I do not see any issue nor bug here, this is expected behavior… If you think this should be changed, then please use forums, ML (bf-funboard) and IRC to start a discussion about it.

expected behavior from who's perspective? a coder or a user? from "my" user perspective this can be defined as a bug since the expectation is that everything is either shown in the same range.

I use blender every day for commercial design / engineering. I work solely in millimeters, and get frustrated that I enter millimeters but blender defaults to meters. This means I always need to enter my dimensions in decimals of meters, or add the 'mm' at the end. It would make my work way easier if I could choose which scale of units to work in eg km, m, mm, etc, and if blender remembered this.

@wire donkey (wiredonkey) Suggest you do not resurrect one year old tasks, don’t use our tracker for user support requests, and learn how to use unit system (Setting unit system to metrics, and scale to 0.001, and you don’t need to type in any units to get your values entered in millimeters by default).