Page MenuHome

Loading certain Jpeg causes system alert sound (Win32)
Closed, ResolvedPublic

Description

Windows 10 Professional 64
Intel i5-4200U
Intel HD 4400
Driver 10.18.15.4256
Blender Buildbot 946b850

Short description of error
Image texture create sound with jpeg image

Exact steps for others to reproduce the error
Open Blender add material to cube, open node editor, add image texture node.
Open attached image in image node.
Does not happen in Linux.

Reported from Kasper^ in IRC.

Cheers, mib

Event Timeline

Wolfgang Faehnle (mib2berlin) raised the priority of this task from to Needs Triage by Developer.
Wolfgang Faehnle (mib2berlin) updated the task description. (Show Details)

anyway on testing this on something other then windows 10?

I am sorry, forgot to mention, Kasper^ report the issue on Windows 7.

ok, I cant test because the sound on so i my laptop is broken currently

Campbell Barton (campbellbarton) closed this task as Invalid.EditedSep 9 2015, 9:06 AM

Please give exact details on what is happening.

  • Is this playing sound through your audio system?
  • How long does it play for, what kind of sound is it?
  • If you change the sound-system to None in Blender's System Preferences, does this still happen?... (Also worth testing if SDL for example has the same issue).
  • Does this happen every time, if you add a second image texture does it happen again?
  • Does saving the image as a PNG and loading that cause the same issue?
Campbell Barton (campbellbarton) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.

Hi Campbell

  1. Yes
  2. 3 Marks, kind of Windows system sound
  3. None, SDL or OpenAL make no difference, sound always play after loading image
  4. Yes
  5. No, save image as png with paint and loading does not play sound

Some more Q's

  • does this happening opening the JPEG in the image window.
  • if you re-save the image (open and save as JPEG with new name)
  • if you save the blend file and load it again... does it happen on load (since it must load the image to display it)

Also, you didnt say how long the plays for.

confirmed on buildbot Blender-2.75.0-git.7fab7b6-AMD64

its standard "Beep" everytime when you load only "this" image

mingw-w64 builds dont have this issue

Campbell Barton (campbellbarton) renamed this task from Image texture create sound to Loading certain Jpeg causes system alert sound (Win32).Sep 9 2015, 12:04 PM