Page MenuHome

Pass Index not working on Transparent BSDF
Closed, InvalidPublic

Description

System Information
Linux 64bit + Nvidia GTX 770

Blender Version
Broken: Official 2.75a

Short description of error
Surfaces using transparent BSDF with Pass Index not showing when viewed through ID Mask node

Exact steps for others to reproduce the error
Open attached blend file and render a frame. Face with transparent shader has Pass Index 2. I would expect the "window" to be white in the compositer.

Details

Type
Bug

Event Timeline

Ejner Fergo (ejnersan) set Type to Bug.
Ejner Fergo (ejnersan) created this task.
Ejner Fergo (ejnersan) raised the priority of this task from to Needs Triage by Developer.

set the "alpha threshold" to 0 then it works (?)

set the "alpha threshold" to 0 then it works (?)

Hmm, yes it works. Not sure why as it isn't very intuitive, and can't see why it should affect a material ID pass to be honest.
Edit: Ok maybe in some situations I guess. Have to test.

Thanks anyway!

Sergey Sharybin (sergey) closed this task as Invalid.
Sergey Sharybin (sergey) claimed this task.

As tooltip says, Index passes are affected by alpha threshold. This is so you can either get data passes of window itself or from geometry outside of the window.

So thanks for the report, but it's not a bug.