Page MenuHome

Action Actuator - Flipper Mode Frame Glitches
Closed, ArchivedPublic

Description

System Information
win7 64bit

Blender Version
Broken:
2.75 buildbot from 15.9.2015
2.75a official
2.74 official

Worked:
no exact clue - it worked definitly in 2.49b
there have been some Bugreport for this exact topic in Blender 2.71 too - these where solved back then

Short description of error
Frame Glitches in Action Actuator - Flipper Mode
Start and End-Frame sometimes stops 1 frame too early at start - or to late at end

Exact steps for others to reproduce the error

  • open blend
  • press P
  • press right CTRL key several times
  • see the right "flipper" object stopping at wrong frame sometimes

****BAD WORKAROUND
on the left "flipper" object (use left CTRL key) i do a bad workaround in the Action-Actuator
i set the Start-Frame -1 (to frame 0 istead of 1)
and the End-Frame +1 (to frame 9 instead of 8)
this will fix the glitch but will introduce a not precise animation / reaction

****NOTES
this occurs independent of "animation framerate" setting - wich is set to 60 in this case

thank you and have a good day, Tobi

Details

Type
Bug

Event Timeline

Tobias Lijsen (blenderhilfe) created this task.
Tobias Lijsen (blenderhilfe) raised the priority of this task from to Needs Triage by Developer.
Aaron Carlisle (Blendify) renamed this task from BGE - Action Actuator - Flipper Mode Frame Glitches to Action Actuator - Flipper Mode Frame Glitches.
Aaron Carlisle (Blendify) claimed this task.
Aaron Carlisle (Blendify) removed Aaron Carlisle (Blendify) as the assignee of this task.

I did some digging, and it worked fine in 2.70a, but was broken in 2.71. It may have something to do with the patch for T41168. If the action is fully played, and then the trigger removed (in this case, you release the RCTRL key), it should play back to the first frame. However, it doesn't update the object, even though BL_Action::Update(float curtime) and BL_Action::UpdateIPOs(float curtime) are called with the correct curtime.

@Tobias Lijsen (blenderhilfe): The glitch is fixed in rB728d1ec504647f512aeb46d3eb7b15d262d94246.
@Sybren A. Stüvel (sybren): I confirm for the flipper action not backed, but it's not the subject of this task. We should change it for this bug or close it ?

@Sybren A. Stüvel (sybren): I confirm for the flipper action not backed, but it's not the subject of this task. We should change it for this bug or close it ?

I don't know what you mean with "the flipper action not backed", but I think things should just work. If you can, just fix the bug you found :)

Aaron Carlisle (Blendify) closed this task as Archived.Sat, Jun 29, 2:18 AM
Aaron Carlisle (Blendify) claimed this task.

This task is being closed because the BGE has been removed in Blender 2.8.