Page MenuHome

Rendering only takes into account the render border of the current scene when compositing
Closed, ArchivedPublic

Description

System Information
Windows 7 64-bit, Nvidia gtx570

Blender Version
Broken: 2.76 36d6424
Worked: -

Short description of error

I have two scenes, one with a cube in the top left of the camera's view and another scene with a cube in the bottom right of the camera's view. Each scene has a separate render border around that scene's cube. In one of the scenes I have compositing set up to render both scenes and lay them over each other (transparent background is enabled in one of the scenes to allow this). When I render the frame I find that both scenes are rendered using the render border of the current scene instead of taking into account each scene's individual render border, which means the final render appears blank (as the empty area of one scene is overlaid on the other).

This can be fixed, but only by pressing the render button on the render layer node for the scene that rendered incorrectly. When I do that, it uses the correct render border for that scene.

Not sure whether this is a bug or intended, but not what I personally expect.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

  1. Render the current frame.
  2. Either by looking at the rendered output of the viewer node via the image editor, or by looking at the render layer thumbnails, you can see only the top left was rendered for both scenes.
  3. Press the 'render' icon on the render layer that rendered incorrectly (with scene name "Bottom Right") to re-render using the correct border.

Details

Type
Bug

Event Timeline

Ray Mairlot (madog) updated the task description. (Show Details)
Ray Mairlot (madog) raised the priority of this task from to Needs Triage by Developer.
Ray Mairlot (madog) set Type to Bug.
Sergey Sharybin (sergey) closed this task as Archived.Sep 21 2015, 10:57 AM
Sergey Sharybin (sergey) claimed this task.

This is workign as designed and expected and in fact it's the only wayt you can have usable border render for scenarios when your scene is split into several render layers/scenes for the performance reasons.. For example, you might want ot render volumes in BI, rest of geometry in Cycles and combine them together. With your suggestion you'll need to change render border in every scene every time you want ot preview different area of your frame.

Soe thanks for the report, but it's not considered a bug.