Page MenuHome

New Depsgraph: When making proxy, it doesn't modify/deform linked objects till reload the file.
Closed, InvalidPublic

Description

Sorry, I don't have time to make a file.

  • Make an armature
  • Link the cube to the bone
  • Add them to a group.
  • Save the file.
  • Open a new file.
  • Link that group.
  • Make proxy of the armature
  • Move the bone: the linked cube doesn't move.
  • Save the file, reload it: the cube moves.

There's a similar bug, but in a different action. I'm reporting it, too.

Event Timeline

Mario Mey (mariomey) raised the priority of this task from to 90.
Mario Mey (mariomey) updated the task description. (Show Details)
Mario Mey (mariomey) edited a custom field.
Bastien Montagne (mont29) changed the task status from Unknown Status to Invalid.Sep 25 2015, 2:45 PM
Bastien Montagne (mont29) claimed this task.

I cannot confirm that here, made a quick check, everything works immediately after 'making local', be it parent to bone or parent to armature with deformation vgroups.

Sorry, I don't have time to make a file.

Well, next time avoid reporting altogether then, and wasting our time as well - if we ask for a .blend file, it’s not just for the fun of it, it’s because we need it 99% of time to be able to quickly reproduce the reported issue. Oh, and btw, please follow our submission template and guidelines next time (you know, blender version, OS, etc.), those are also mandatory.

I make a video and upload the first file to be linked. I'm really sorry about not following the template.

System: Ubuntu Mate 14.04 x64, nVidia GT620
Blender version: 2.76-rc2 (from blender.org)

I'm using new depsgraph.

The bug is in the new depsgraph. Using old depsgraph, it works as spected.

Bastien Montagne (mont29) changed the task status from Invalid to Unknown Status.Sep 25 2015, 4:05 PM

*sigh* again, indeed new depsgraph is important part of the issue…

Cannot reproduce it with latest master though, can you please try the latest build from our buildbot?

Bastien Montagne (mont29) renamed this task from When making proxy, it doesn't modify/deform linked objects till reload the file. to New Depsgraph: When making proxy, it doesn't modify/deform linked objects till reload the file..Sep 25 2015, 4:05 PM
Bastien Montagne (mont29) removed Bastien Montagne (mont29) as the assignee of this task.
Bastien Montagne (mont29) lowered the priority of this task from 90 to 30.

Yes, I tested with de80e69.

Bastien Montagne (mont29) raised the priority of this task from 30 to Normal.Oct 2 2015, 12:26 PM

The issue reported can't be reproduced so far, and has been moved to the BF Blender: Unconfirmed project.
If 2 other people aren't able to redo the bug after 2 weeks, it will be closed.

We appreciate the effort that goes into making bug reports, but to be able to fix bugs we have to be able to redo them.
If there is anything you can provide to help others to reproduce the problem, be sure to include it.

I just tested it with blender-2.76-550527b-linux-glibc211-x86_64, from builder bot. It does the same, exactly as the video shows.

Also, I found some other stuff (that I don't actually remember) that it was necessary to reload the file to start working. So, unless it is a problem in my computer and config (that I doubt about it), I think the bug is there.

It's strange that you @Bastien Montagne (mont29) couldn't reproduce it. Did you remember to use the new depsgraph?

Aaron Carlisle (Blendify) changed the task status from Unknown Status to Unknown Status.Jun 29 2019, 2:51 AM
Aaron Carlisle (Blendify) claimed this task.