Page MenuHome

Regression: Scene Layer settings are not respected
Closed, InvalidPublic

Description

System Information
Debian AMD64, fglrx-driver

Blender Version
Broken: 2.72 and later
Worked: 2.71

Short description of error
All activated scene layers (under the Render Layers tab) should be rendered, but only the scene layers set in the 3D-viewport are rendered.

Exact steps for others to reproduce the error
Here is a .blend file:


Press F12 to render.

Two objects are located on two separrate scene layers. Both layers are activated, so both objects should be rendered.

Thank you!

Details

Type
Bug

Event Timeline

Robert M (robertm) raised the priority of this task from to Needs Triage by Developer.
Robert M (robertm) updated the task description. (Show Details)
Robert M (robertm) set Type to Bug.
Bastien Montagne (mont29) claimed this task.

Please do not set regression flag yourself, this is dev task to decide.

And this si not a regression at all, this is a fix in fact! When invoked (with f12 shortcut) from a 3DView which settings are not locked with Scene's ones, render uses that 3DView settings, this is intended feature to allow artists to quickly be able to render different sets of layers and/or cameras e.g.

Thanks, for the explanation, Bastien.
I found a setting in the preferences called "Use 3D Viewport" (Screen->Render). I had to deactivate it for my purposes.
Still for quick preview renders we could have another shortcut like ALT+F12, because I think many artist are not aware of this feature.
Just my opinion.