Page MenuHome

Cycles point density interpolation failing
Closed, ResolvedPublic

Description

Hi Sergey,

this one's for you... sorry!

System Information
i7 16GB RAM, 2*GTX 560 ti oc 2GB each, Ubuntu 64 15.04

Blender Version
Broken: 83a94cb

Short description of error
Switching the interpolation type from "closest" to "linear" in the appending file (

) will create cloud parts at the domain borders. It's more prominent with smaller resolutions.

Exact steps for others to reproduce the error
Preview render with Shift+Z, switch the interpolation type from "closest" to "linear" in the appending file -> at the lower domain border a new cut cloud is appearing. Try "Cubic" afterwards to see even more cloud parts at the borders (the left side).

Apart from that:

  • I got several crashes when I move the domain while being in Shift+Z mode... seems like a threading issue...
  • Moving the domain (G) and aborting the movement by RMB will cut the cloud

Many greetings,
Thomas

Event Timeline

Thomas Beck (plasmasolutions) updated the task description. (Show Details)
Thomas Beck (plasmasolutions) raised the priority of this task from to Needs Triage by Developer.

I got a crash once when accidentally connecting the point density node to the displacement output

@Aaron Carlisle (Blendify), please don't mix different issues into a single report. Find a reproduceable case and submit a separate report.

@Sergey Sharybin (sergey) the report mentions this more or less:

I got several crashes when I move the domain while being in Shift+Z mode... seems like a threading issue...

@Aaron Carlisle (Blendify) This was just an additional info. When I like this specific bug to be fixed, I'll report that separately with a file that shows the issue. Otherwise it's just guessing...

@Sergey Sharybin (sergey) tested it and it works tiptop - thanks!