Page MenuHome

Defocus node not working on Windows 32 bit
Closed, ResolvedPublic

Description

i cant get the depth of field effect with the defocus node since blender 2.75 .
i had seen other people have my problem to .
defocus node was ok in blender 2.73 !
sorry for bad english !

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Oct 8 2015, 9:55 AM

Please follow our submission template and guidelines and make a complete, valid bug report, with required info, precise description of the issue, precise steps to reproduce it, small and simple .blend and/or other files to do so if needed, etc.

{F243369}hello
if you open the scene with blender 2.75 and higher, the defocus node wont work !
but if you open it with blender 2.73 and lower you get the effect !
seems like the defocus node had broken since 2.75 !
sorry for bad English .

Cannot confirm that here, afaikt defocus node is working fine in your file, in both official 2.75a and latest master… Please define 'does not work' (you can also add screeshots to illustrate your issue).

sounds like T45425 could it be an issue with older computers?

Sounds pretty similar indeed. Fact is, I still cannot confirm that here, for me defocus is working as expected…

@Soushiant Joshaghani (Soushiant) can you give us you precise OS, CPU & GPU (including drivers) versions?

2 system that i have :

1- windows 7
core i7 3ghz
8gb ram
2 gb gpu memory

2-windows xp sp3
core 2 duo 2.66
4 gb ram
geforce 9300m gs

doesn't work on both of them !

nvidia 335.23
graphic driver

I can confirm the problem with the 32 bit 2.76 RC3 build, but not the 64 bit build.

This is on Windows 10 with an Intel Core i7-4790K CPU.

Brecht Van Lommel (brecht) raised the priority of this task from Needs Information from User to Confirmed, Medium.Oct 9 2015, 1:51 AM
Brecht Van Lommel (brecht) renamed this task from Defocus Node Doesnt Work !!! to Defocus node not working on Windows 32 bit.Oct 9 2015, 2:20 AM

The 32 bit Linux build seems to work fine, so it's Windows specific somehow.

I can reproduce the issue with official builds but not with own builds, which makes it much more tricky to troubleshoot.

Same as @Sergey Sharybin (sergey) here, can reproduce with official 2.76 & buildbot builds (win32), but not with own 32bit build (using cmake)…

Will try to use buildbot (with experimental-build branch) to isolate a bit more the issue :|

Okay, so all I learned after a whole day of buildings adventures, is that bug is:

  • Not present in official 2.74 release.
  • Present in official 2.75 release.
  • Present in a 'fake' 2.74 build made with current buildbot! (using rB7871d1358 from experimental branch).

So it seems to be something caused by current build environment, a change between 2.74 and 2.75, which is causing the issue, and not a change in code? @Martijn Berger (juicyfruit), we need your science here. :)

Sergey Sharybin (sergey) closed this task as Resolved.Jan 28 2016, 11:48 AM
Sergey Sharybin (sergey) claimed this task.

Should be fixed now in latest Git. Thanks for the report.