Page MenuHome

Blender Player stutters when navigating rendered image sequence
Closed, ResolvedPublic

Description

System Information
Operating system and graphics card
Windows 7 Ultimate
GeForce GTX 480

Blender Version
Broken: 2.76 48f7dd6
Worked: 2.75

Short description of error
Blender Player stutters when navigating rendered image sequence (PNG, TIF tested) by dragging with the left mouse on the screen.

Exact steps for others to reproduce the error
Play rendered image sequence (not video file) by pressing Ctrl+F11 or from the command prompt using "blender -a [path to first image in the sequence]"
When in play mode - the playback is fine.
When in "drag" mode the player lags while displaying frames. Clicking on different points in the screen loads the image frame faster.
This behavior is the same, no matter the time indicator is on or off (by pressing I on the keyboard).

Event Timeline

Rumen Belev (syziph) updated the task description. (Show Details)
Rumen Belev (syziph) raised the priority of this task from to Needs Triage by Developer.
Rumen Belev (syziph) set Type to Bug.

While I couldn't redo the bug. I suspect this is caused by mouse motion adding a lot of *in-between* events, which can be at a higher FPS then the playback rate. In this case your system could get behind in loading them.

Suggested fix is to skip mouse events if there are other mouse events - ahead in the queue, using GHOST_EventManager::peekEvent.

Can you confirm that this doesn't happen for low-res images? (100x100 or so).

I confirm that there is no problem at 100x100 resolution.

Its also possible that updating the state of the audio driver is giving some overhead, could you try set audio output to None in the system preferences.

Seting the Audio Device to none does not fix this problem.

This bug at high resolutions render, such as 1920X1080.
50% render no bug, as 100% there is a bug .
My English is very bad, sorry.

Alexander (Lunar) reopened this task as Open.Nov 4 2015, 11:08 PM

This bug at high resolutions render, such as 1920X1080.
50% render no bug, as 100% there is a bug .
My English is very bad, sorry.

The new version of blender 2.7b this problem remained.

Bastien Montagne (mont29) closed this task as Resolved.Nov 6 2015, 9:39 PM
Bastien Montagne (mont29) claimed this task.

Please do not reopen bug yourself.

And fix is in master (you can test it by downloading the latest build from our buildbot), not in 2.76b release.

Alexander (Lunar) added a comment.EditedNov 7 2015, 11:14 PM

The bug is present in version https://builder.blender.org/download/blender-2.76-02f3ceb-win64.zip. Sorry for the opening of a bug.
At a resolution 960x540 and below, the error is not observed. If the resolution is higher than 960x540 (eg 1920X1080) error appears again.
Possible problem in the pre-cache?

The bug is present in version blender-2.77-windows64.
At a resolution 960x540 and below, the error is not observed. If the resolution is higher than 960x540 (eg 1920X1080) error appears again.

Likely this lag may just be time loading the files then.