Page MenuHome

Use Alpha (Straight/Premultiply) option missing in 2.76
Closed, ResolvedPublic

Description

System Information
Windows 7, Nvidia GTX 560

Blender Version
Missing: 2.76
Worked: 2.75

Short description of error
When using TGA or DDS files as Z Transparency alphas, the Use Alpha and Alpha Modes (Straight/Premultiply) is not available.

Exact steps for others to reproduce the error

  1. Open attached file.
  2. Go to Materials tab
  3. Note that texture is a DDS file.
  4. Note that Use Alpha and Alpha Modes are not visible.

Based on a (as simple as possible) attached .blend file with minimum amount of steps

Event Timeline

Chris (raindance) updated the task description. (Show Details)
Chris (raindance) raised the priority of this task from to Needs Triage by Developer.
Chris (raindance) added a project: BF Blender.
Chris (raindance) set Type to Bug.
Bastien Montagne (mont29) triaged this task as Confirmed, Medium priority.Oct 18 2015, 10:42 AM

Confirmed, issue comes from the fact imagetype is set to R_IMF_IMTYPE_JPEG90 instead of expected R_IMF_IMTYPE_DDS… Investigating further…

Thank you! DDS is now fixed in October 19's build at builder.blender.org.

However, I notice the problem persists for TGA files. Can you fix that too?

Much appreciated!

@Chris (raindance) can you please attach here a (small! ;) ) failing TGA? Here I do have alpha settings for those…

Bastien Montagne (mont29) lowered the priority of this task from Confirmed, Medium to Needs Information from User.Oct 20 2015, 7:44 AM

Hi Bastien,

Thank you for looking into this! Much appreciated.

File attached. <40MB.

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Confirmed, Medium.Oct 20 2015, 7:53 PM

Thanks, can confirm the issue with this TGA… Odd with the one I tested everything was OK, will investigate again!

Thank you Bastien! Can confirm it works in latest build.