Page MenuHome

OpenGL transparent render alpha doesn't work with DOF
Closed, ArchivedPublic

Description

System Information
Win7 x64
GTX 780 Ti

Blender Version
Broken: Master as of Oct 18

Short description of error
When viewport depth of field is enabled, OpenGL renders no longer support transparent background.

Exact steps for others to reproduce the error
Enable viewport DoF, OpenGL render.

Details

Type
Bug

Event Timeline

Matt Heimlich (m9105826) set Type to Bug.
Matt Heimlich (m9105826) created this task.
Matt Heimlich (m9105826) raised the priority of this task from to Needs Triage by Developer.
Campbell Barton (campbellbarton) triaged this task as Needs Information from User priority.

Was this ever supported, if so which version?

Please always include basic info like this.

There is some alpha, but it's the original unblurred alpha which gives artifacts. The issue is that during blurring the alpha channel is used to store the circle of confusion. Multiple render targets could solve that.

You need to enable transparent sky. We could have proper blurred alpha but this will indeed require some extra draw overhead for the extra draw buffer. I guess correctness is more important than performance though

Bastien Montagne (mont29) closed this task as Archived.

Time to archive I think… Our 3D team is aware of it and can make it a TODO item if needed.