Page MenuHome

Blender crashes when clicking back and forth in VSE timeline
Open, Confirmed, LowPublic

Description

System Information
Debian 8 Xfce (Linux version 3.16.0-4-amd64)
NVIDIA GTX 970

Blender Version
Broken: 2.76
Worked: never (all versions I tried had this problem)

Short description of error
While working in VSE mode with Audio scrubbing and AV-sync activated,
if I click back and forth in the timeline too fast it causes a crash (segmention fault).

Exact steps for others to reproduce the error
Load Full HD file into blender VSE
Click back an forth in the timeline very fast:
Blender crashes.

It's not that I need blender to be able to click back and forth too fast, but while working normally, it unfortunately happens as well, which is at times quite annoying.
Thanks in advance!

# backtrace
./blender(BLI_system_backtrace+0x1d) [0x1a3de6d]
./blender() [0x10567e4]
./blender() [0x10569c1]
/lib/x86_64-linux-gnu/libc.so.6(+0x35180) [0x7fccc0546180]
./blender(_ZN18AUD_SoftwareDevice3mixEPhi+0xa6) [0x229baf6]
./blender(_ZN14AUD_JackDevice17updateRingBuffersEv+0x160) [0x228fff0]
./blender(_ZN14AUD_JackDevice15runMixingThreadEPv+0x9) [0x2290139]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x80a4) [0x7fccc0ece0a4]
/lib/x86_64-linux-gnu/libc.so.6(clone+0x6d) [0x7fccc05f704d]
# Blender 2.76 (sub 0), Commit date: 2015-10-11 06:55, Hash 48f7dd6

# backtrace
./blender(BLI_system_backtrace+0x1d) [0x1a3de6d]
./blender() [0x10567e4]
./blender() [0x10569c1]
/lib/x86_64-linux-gnu/libc.so.6(+0x35180) [0x7fa670567180]
./blender() [0x1675524]
./blender(_ZN14AUD_JackDevice17updateRingBuffersEv+0xc9) [0x228ff59]
./blender(_ZN14AUD_JackDevice15runMixingThreadEPv+0x9) [0x2290139]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x80a4) [0x7fa670eef0a4]
/lib/x86_64-linux-gnu/libc.so.6(clone+0x6d) [0x7fa67061804d]

Details

Type
To Do

Event Timeline

Miranda (ebename) added a project: BF Blender.
Miranda (ebename) set Type to Bug.
Miranda (ebename) created this task.
Miranda (ebename) raised the priority of this task from to Needs Triage by Developer.
Aaron Carlisle (Blendify) triaged this task as Needs Information from User priority.

Hi, I cant seem to reproduce this can you post .blend with video which can be used to reproduce this. I also currently don't have and audio output driver for my computer so that may change things.

Hi,

I could reproduce the bug with jack and old (default) audaspace. Are you using Jack on purpose?

I tried to debug the code, but although it keeps crashing reproducible at the same spot, I cannot figure out what the problem is. A boost::shared_ptr somehow gets null although it shouldn't and I can't figure out why/where.

The bug is not appearing with the new audaspace version. I didn't change anything in the crashing area of code, although I'm not sure that a tiny change might have fixed this problem. But if not, the bug is probably cause by boost somehow? No clue what to do anymore, but it will be fixed in 2.8. ;-)

Cheers

Aaron Carlisle (Blendify) changed Type from Bug to To Do.
Aaron Carlisle (Blendify) claimed this task.
Aaron Carlisle (Blendify) lowered the priority of this task from Needs Information from User to Confirmed, Low.