Page MenuHome

Custom node bug: mute mode
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card

Blender Version
Broken: (All)
Worked: (None)

Exact steps for others to reproduce the error

Details

Type
Bug

Event Timeline

Alexey (Inwader77) updated the task description. (Show Details)
Alexey (Inwader77) raised the priority of this task from to Needs Triage by Developer.
Alexey (Inwader77) added a project: Python.
Alexey (Inwader77) set Type to Bug.
Sergey Sharybin (sergey) closed this task as Archived.Oct 27 2015, 7:00 PM
Sergey Sharybin (sergey) claimed this task.

Muting nodes requires special function to update internal link (basically to define which input to pass through). This function was not yet exposed to the python API.

So thanks for the report but it's not a bug.

Is there any plan to work on this because this would be extremely useful.

John Roper (johnroper100) triaged this task as Normal priority.Sep 16 2017, 11:33 PM
John Roper (johnroper100) reopened this task as Open.

I added code that updated the node.mute value however, nothing happens. I'm guessing it is that the problem above still exists?

Sergey Sharybin (sergey) closed this task as Archived.Wed, Jan 23, 3:28 PM

The documentation you've linked works for a "built-in" nodes. Currently python nodes do not support muting. This can be annoying for some usecases, but lack of functionality is not considered a bug and should be handled outside of the bug tracker.