Page MenuHome

OpenGL display problems with submenus on MS-Windows
Closed, ArchivedPublic

Description

System Information
Windows 10
Intel HD Graphics 5300 (UHD 3200x1800) onboard
PC is a Lenovo Yoga3 Pro ultrabook, no separate graphics card.

Blender Version
Broken: 2.76
Worked: 2.74

Short description of error
If any viewer window is open (I tried them all), when selecting a menu that has a submenu (for example File > Open Recent...) the viewer window goes to full screen, instead of showing the submenu. On several windows (for example user settings) the viewer window start flickering wildly.

I tried to change the user settings (especially OpenGL settings) but it didn't help. I repaired the installation, also didn't help. When using default display resolution settings etc. it still happens.

I am now going to downgrade back to 2.74, which is annoying because I need a 2.76 feature... oh well. I still love Blender, though ;)

Exact steps for others to reproduce the error

  1. Select File > Open Recent...

The viewer window flips to full screen view, or clean UI or whatever you call it these days.

  1. Click the arrows in the top right corner to go back to normal view.
  2. Use the icon selector in the lower right of the viewer window to change the viewer window to the User Settings window.
  3. Select File > Open Recent...

The User Settings window starts flickering madly.

Details

Type
Bug

Event Timeline

Petrik de Hair (psd) raised the priority of this task from to Needs Triage by Developer.
Petrik de Hair (psd) updated the task description. (Show Details)
Petrik de Hair (psd) set Type to Bug.
Campbell Barton (campbellbarton) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Oct 26 2015, 7:53 AM

Its highly likely that this bug is specific to your hardware/driver configuration.
These kinds of display issues are often caused by OpenGL driver bugs.

While its possible a software error in Blender, its worth checking if this functions correctly...

  • After upgrading graphics card drivers.
  • On a different system (with different hardware/drivers).
  • Using a Software OpenGL renderer...

If this is a driver bug, or we can't link to this to an error in Blender's code, the report may be closed as a driver error,
so please help us determine whether this is a bug in Blender or not.

Campbell Barton (campbellbarton) renamed this task from Viewer window goes to fullscreen when selecting menu with submenu to OpenGL display problems with submenus on MS-Windows.EditedOct 26 2015, 8:01 AM

Could you show a screenshot of the error?
Also please double check if this works in 2.75 or not.

This sounds similar to T46596, an error reported on OSX. (also reports regression with submenus in 2.76, working in 2.74)

Sergey Sharybin (sergey) closed this task as Archived.Nov 3 2015, 1:29 PM
Sergey Sharybin (sergey) claimed this task.

More than a week without reply. Due to the policy of the tracker archiving the report for until requested information is provided.