Page MenuHome

Converting particle to real is converting all particles
Closed, ArchivedPublic

Description

System Information
W10 64b

Blender Version
2.76

Short description of error
If you have more particle system and you click to Convert button, all particles will be converted to mesh, not only selected.

Exact steps for others to reproduce the error

  1. open
  2. select sphere and click to Convert button in modifiers
  3. both particle systems are converted, not only selected.

Details

Type
Bug

Event Timeline

Cenek Strichel (cenda) raised the priority of this task from to Needs Triage by Developer.
Cenek Strichel (cenda) updated the task description. (Show Details)
Cenek Strichel (cenda) set Type to Bug.

In fact, convert button is just a trick about another trick.
Object display type of particles reuse dupliframes, dupliverts display code that don't manage a selection.
So, particles convert button is calling operator to make duplicates real.
And this operator is working on all duplicates displayed on the scene.

A workaround to limit conversion to a specific particle system is to disable display of others particle systems.

It would be great, if it will do Blender automatically for me ;) It will be another trick, but expected behaviour.

Sergey Sharybin (sergey) closed this task as Archived.Oct 27 2015, 4:08 PM
Sergey Sharybin (sergey) claimed this task.

It's a bit more tricky than simply temporary disable particle systems because of possible threading conflicts. In any case this is more an improvement request rather than a bug, the title explicitly says that all associated objects will be created.

So thanks for the report, but it's not really a bug.