Page MenuHome

Undo doesn't work on unparenting an object in armature-edit-mode.
Closed, ArchivedPublic

Description

Ubuntu 14.04 x64
nVidia GT620

Broken: Blender 2.76 48f7dd6 (from blender.org)

  • Open the file (it is in Armature Edit Mode and the armature parented to the wire-cube)
  • Use the left panel to clear object's parent (Object Panel - Relations - Parent - click on the "X")
  • Press Ctrl-Z: it doesn't make the armature parented to the cube again.

Details

Type
Bug

Event Timeline

Mario Mey (mariomey) raised the priority of this task from to Needs Triage by Developer.
Mario Mey (mariomey) updated the task description. (Show Details)
Mario Mey (mariomey) set Type to Bug.

I can not reproduce this here.
(version: 2.76 (sub 2), branch: master, commit date: 2015-10-29 23:57, hash: d8233d2, type: Release)

May you mistake objects relations for armature relations?

Mario Mey (mariomey) added a comment.EditedOct 30 2015, 1:33 PM

@perfection cat (sindra1961), I discovered the bug by a mistake. I wanted to unparent the bone but I clicked in the object relation panel. So, I unparent the armature (as an object, and because it is parented to another object).

Then, I pressed Ctrl-Z, but it didn't undo.

It's weird... I'm testing the same file I uploaded here and almost everytime, the bug is there. But sometimes, it undoes. I don't know in wich cases.

I just tried in d8233d2.

There is a point not to know in the procedure that you showed in Description.

Use the left panel to clear object's parent (Object Panel - Relations - Parent - click on the "X")

What is "X"?
Can you show the snapshot of the screen or a clear procedure?
(with an operation mode definitely)

The procedure that I tried.

  1. Open the attached file.
  2. Press Tab key. (to Object-mode)
  3. Clear the parent of the object with the left panel. (Object Panel - Relations - Parent - Clear)
  4. Press Ctrl-Z.

Thanks for the response. Please, follow the steps as I wrote. I didn't say go to Object mode, but stay in Edit Mode and use this panel and this "X" (close icon) to unparent the object.

This is a screencast:

Sergey Sharybin (sergey) closed this task as Archived.Nov 3 2015, 12:19 PM
Sergey Sharybin (sergey) claimed this task.

This is a famous discontinuity in the undo system of blender listed in our TODO list. Basically, when you're in armature edit mode local undo stack is used to store bones modifications, it doesn't store all the possible modifications happening to the .blend file -- those goes to the global undo stack which is active in object mode.

So thanks for the report, but it's just how Blender works.

Mario Mey (mariomey) added a comment.EditedNov 3 2015, 3:52 PM

I understand. Actually, if I go back to Object Mode, Ctrl-Z makes the undo.

Thanks!