Page MenuHome

Cycles material preview icon is affected by world material
Closed, ArchivedPublic

Description

System Information
64-bit Linux NVIDIA GTS 450

Blender Version
Broken: 2.76 (and earlier? verified on 2.73a as well)

Short description of error
Small preview icons in material list are rendered taking world material into account. Thus they differ from an actual material preview in the properties editor.

Exact steps for others to reproduce the error

  1. Open
  2. Observe how material Preview shows the gray-ish glossy ball, while the small icon in the materials list is pink (glossy "reflecting" non-existent environment texture).

Details

Type
Bug

Event Timeline

This might be related: https://developer.blender.org/T34240
Although it's talking about the large material preview (when set to 'World Sphere' type).

I don't know if its tied to the mini material icons.

Sergey Sharybin (sergey) closed this task as Archived.Nov 3 2015, 11:46 AM
Sergey Sharybin (sergey) claimed this task.

Icons are using "Sphere with World" preview type to give a bit better clue about what's the material is doing. So comparison with a sphere in a "studio" environment in preview is not really valid.

So thanks for the report, but it's not really a bug.

Even it it's a feature, it is at the very least inconsistent. That took experienced users a few moments to figure out on a real file, I can't image what new users would make of it.

Can an improvement be made here? I.e. maybe make small previews respect whether "World Sphere" in the "real" preview is selected?

Paul R (intracube) added a comment.EditedNov 3 2015, 6:28 PM

Sergey - since the large preview uses neutral light colour, it makes sense for the small previews to reflect this.

It should be a special case to have the previews reflect the world lighting, IMO, not the default. It gets confusing fast if the user sets a strong world colour and all icon previews 'change'.

In the same way you should choose wallpaper/fabric colours under natural daylight (in the real world), the material previews should follow this.

Just my two cents... or pence :)

EDIT: and the small previews don't often update (depsgraph issue?) which complicates things more. Two identical diffuse grey materials can show differently if the second material is created after the world colour is changed.

Ignoring world for the icon will re-introduce T34240 which is also not good. In any case, not saying improvements can't happen but bug tracker is not an appropriate place for discussing possible ways to go.

Ignoring world for the icon will re-introduce T34240 which is also not good.

I'm not suggesting just reverting back. It shouldn't be either-or.

As I said, this isn't working properly anyway due to the UI not updating. To highlight;

  • first three grey materials were created when World colour was the default grey
  • World colour was set to orange, then fourth 'grey' material was created
  • World colour was set to green, then fifth 'grey' material was created

So we have five materials, all grey, displaying differently.

Depsgraph limitations are a known, of course. But having material previews try and reflect the world colour when they can't be updated reliably has led to this bug (which is a slightly different issue to the original ticket description).

This is nothing to do with the depsgraph at all. This term is being really overused this days, which is only increasing confusion in the community.

For now you can just use refresh datablock previews button to make sure previews are all up to date. Sure enough it's nice to have happening automatically, but then all of a sudden you'll have quite a slowdown in a production shots when tweaking world settings which isn't really great either.

Paul R (intracube) added a comment.EditedNov 6 2015, 11:44 PM

This is nothing to do with the depsgraph at all. This term is being really overused this days, which is only increasing confusion in the community.

Sorry, I wasn't sure.

For now you can just use refresh datablock previews button to make sure previews are all up to date.

I tried File->Data Previews->Refresh DataBlock Previews -- no effect on the icons :(

Sure enough it's nice to have happening automatically

It's really important that they update automatically and reliably or not at all!

but then all of a sudden you'll have quite a slowdown in a production shots when tweaking world settings which isn't really great either.

Another argument for not factoring in World colour.