Page MenuHome

As of 2.76 Cycles matcap materials no longer work
Closed, InvalidPublic

Description

System Information
OS X 10.10.1
ATI Radeon HD 4850 512 MB

Blender Version
Broken: 2.76 48f7dd6
Worked: 2.76 rc3 fb78f6d

Short description of error
The established node setup for Cycles matcap materials no longer works in 2.76. I don't mind changing the setup if that is what is required, but if there is no way to create matcap materials in Cycles that is a problem. Is this the result of a change of standards for how vector data is handled, or did something just simply break?

This may or may not be related to a bug I submitted on Oct 7th which involved this node setup breaking specifically when Open Shading Language was enabled. (That bug was resolved.)

Exact steps for others to reproduce the error
Observe the .blend when opened in 2.76 rc3 versus in 2.76 - the node setup does not produce a matcap result anymore in 2.76.

Details

Type
Bug

Event Timeline

Seth L. (quantumanomaly) set Type to Bug.
Seth L. (quantumanomaly) created this task.
Seth L. (quantumanomaly) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) closed this task as Invalid.
Bastien Montagne (mont29) claimed this task.

You simply need to switch your TransformVector node from 'Point' to 'Normal' mode - wonder how it could work at all in 'Point' mode previously, probably because transform did not take all elements (location one esp.) into account?

Ha! So it was a fluke that it worked before. Well now we know the correct way to do it, so that's good. Thank you for looking into it and explaining.