Page MenuHome

System requirements on are misleading
Closed, ResolvedPublic


System requirements page ( states:

"Graphics card note: Blender runs on all OpenGL-compatible cards, although there are some issues with integrated graphics cards (Intel, Via). We therefore can’t officially support and guarantee that Blender works fine on those systems."

Pre-GL2.0 cards (not necessarily "integrated" ones) are omitted from that note entirely. From those requirements, someone running a GL 1.5 NVIDIA card will expect Blender to work on their system, and while it indeed may run, it's likely to not provide a comfortable working environment.

System requirements should state that Blender might have issues running on GPUs which don't support at least GL2.0.


As new versions are released, more and more people with older GPUs start experiencing issues with viewport. There are a great many of reports on this tracker closed as "driver issue" (simply browse through

Campbell stated on stackexchange back in 2013 (, "So while blender depends on version 1.4. it may use newer features when available and fail gracefully if they are not (as opposed to crashing or not starting at all).", but we're nearing on 2016, and that statement is not true anymore. Modern Blender *may* not start on a GL 1.4 GPU, and many of the "graceful" failures are *not* graceful at all (viewport not updating, fonts as squares, pink/white objects in viewport, etc.), with no comprehensive indication that it's indeed a GPU issue, not a misclicked checkbox or a forgotten obscure setting.

Yet there's no "official" word about this on Viewing the system requirements page, a user would think "hey, I have an OpenGL card, and it's not integrated, Blender will run fine". But if their card is actually a GL 1.4 or 1.5 one, they would be in for an unpleasant surprise.

Screenshot of 2.76 running on a GL1.5 NVIDIA GPU, from today's question in #blender:



Event Timeline

Such people can acquire the Previous releases of Blender.
The Previous releases of Blender works in such an environment.

Previous releases of Blender

@Stanislav Blinov (radcapricorn), Blenders use of OpenGL (for interface and solid mode drawing) doesn't change frequently.

If something broke between releases, you need to be more specific.


fonts as squares

Font drawing method didn't change much since 2009.
Which release did the regression show up?

We should probably note that GLSL shading requires a higher OpenGL version,
But other changes you mention could be a regression too.
So rather those are reported separately.

Such people can acquire the Previous releases of Blender.

Yes, they can, but the point of this report is that current system requirements imply that they should be able to continue using new releases (i.e. all the new awesome features, rendering improvements, modelling tools, exporters, etc.).

@Stanislav Blinov (radcapricorn), Blenders use of OpenGL (for interface and solid mode drawing) doesn't change frequently.
Font drawing method didn't change much since 2009.
Which release did the regression show up?

That list is based on my own experience helping people in #blender troubleshoot their issues. I cannot pinpoint this exact one, unfortunately. Sometimes problems are solved easily by (re-)installing drivers. Sometimes though drivers appear to be in order, yet problems remain, while their blend files work fine on machines with newer cards, or when Blender is running using the bundled software GL implementation (which, by the way, sports GL 2.1, not the "minimum" 1.4). We always advise to report the problem here, but we cannot follow each and every person's progress in that regard. I tried mediating reports in the past, sadly it doesn't work well.

Getting back to system requirements, if asked "where is it said that I need GL 1.4 to run Blender?" we can't even point to Instead, we are pointing to that post you made on stackexchange. Which is, to say the least, not ideal. Adding a simple note that GL 1.4 is a required minimum and issues are possible on all older cards (not just "integrated" ones) will at least make this information "official" (i.e., from the user's point of view not speculation some "random" strangers on IRC, stackechenge, etc.).

Blender is functional on OpenGL 1.4 on a basic level, so its incorrect to say it doesn't work on OpenGL1.4 too.

Tested on Mesa OpenGL:
MESA_EXTENSION_MAX_YEAR="1995" MESA_GL_VERSION_OVERRIDE="1.4" ./blender-softwaregl

Also tested on a virtual machine, Windows Software OpenGL (also 1.4).

In both configurations Blender is usable and not showing bugs or glitches.

Some things don't work of course...

  • GLSL and Matcaps.
  • offscreen rendering.

The issue is, we follow OpenGL 1.4 as a minimum spec, yet older cards often give problems, these things aren't necessarily related (we get bug reports of OpenGL issues with new cards too), we could expand on this in the requirements page though.

...And yet the screenshot in my first post was taken by a user in #blender on a machine with a GeForce 5700 FX LE (GL1.5). Cycles is selected as render engine, Solid shading mode, yet some objects are rendered completely white. As mentioned, same file opened by several people on newer cards didn't show the same issue. I understand that this particular case needs to go in a separate report, but that's not the first (or second, or tenth) time when people come in with similar problems.

The problems with current requirements page is that it:

  • doesn't specify minimum GL version required (sadly, even today the expression "all OpenGL cards" still includes pre-1.4 cards)
  • explicitly warns about possible issues on "integrated" cards (even mentioning specific vendors), although those issues are possible on other cards as well (i.e. it reads as "if you get a 'proper' GPU, Blender will run fine", which might not reflect the reality).

Driver issues with recent GPUs at least might be fixed with driver updates. Old GPUs don't get such benefit pretty much from any vendor, that's why I think it's important to at least mention that in some form as well.

@Stanislav Blinov (radcapricorn):
Do you know that GeForce FX (5xxx) Series supported OpenGL 2.1 by the latest driver?
List of Nvidia graphics processing units

If it is indeed software implementation, as is stated on that page, would it give any benefit over simply running bundled Mesa with blender-softwaregl? Regardless, what users might do to improve their experience with Blender is beside the point of this report. This report is about (lack of) clarity of information on the site, not a particular issue of a particular Blender installation on a particular machine. As it is worded right now, users should expect the software to work without a hitch so long as their GPU supports OpenGL and is not an integrated one.

The font issue usually has to do with quality settings in the driver set to performance instead of quality or so. So it is a driver issue.
The problem, as Campbell mentioned, is that you can't really quantify what "proper support" means. We try to be compliant to the OpenGL standard. However, drivers, even new ones, can be very particular in what they like OpenGL to do. So even newer GPUs can have glitches. For instance take T45117. What newer drivers have is better support, the driver teams still work on them. But this is a no brainer I hope. And in the end, it all depends on having the GPUs available for testing.
For 2.8 if we move to OpenGL 3.2 such requirements will be more enforcableI hope.

Guys! The problem is not in quantifying anything. I appreciate the discussion, but please let's return to the title of this report. The problem is that the system requirements page on

  • does not mention the minimum required version of OpenGL ("all cards" != "1.4 and above")
  • explicitly warns about possible issues on just the integrated GPUs, when in fact such issues are possible on any GPU

Here's what I propose, I hope it will make things clear:

"Graphics card note: Blender should run on all cards that support OpenGL 1.4 and above, though for comfortable work and access to all interactive features at least OpenGL 2.1 card is recommended."

Minimum needed version - check, GL 2.1 for GLSL/offscreen rendering - check, removed the explicit note about integrated cards. Maybe it could be replaced with a warning about potential issues on older GPUs - I don't know anymore.


Minimum (basic usage) hardware

32-bit dual core 2Ghz  CPU with SSE2 support.
24 bits 1280×768 display
Mouse or trackpad
OpenGL 1.4-compatible graphics card with 256 MB RAM

Recommended hardware

64-bit quad core CPU
Full HD display with 24 bit color
Three button mouse
OpenGL 2.1-compatible graphics card with 1 GB RAM

Optimal (production-grade) hardware

64-bit eight core CPU
Two full HD displays with 24 bit color
Three button mouse and graphics tablet
Dual OpenGL 3.2-compatible graphics cards, quality brand with 3 GB RAM

Looks good to me actually.

Thats valid for the current 2.7x series, soon for 2.8x, 3.2 will be the minimum. We should mention that on this page.

Hi Stanislav,

Thanks for the text fix proposal, I will update it on
Help with docs and presentation of Blender is always welcome! If you feel like helping to write or editing more, drop me a mail. (ton at blender org)

Sergey Sharybin (sergey) closed this task as Resolved.
Sergey Sharybin (sergey) claimed this task.

The site was updated now, guess we can mark this one resolved! Thanks everyone :)