Page MenuHome

The subdivision of two edges at once creates an invalid face in certain situations
Closed, InvalidPublic

Description

System Information
Win7 64 bit, 16 igs RAM, an AMD 7xxx GPU, third gen i7 processor

Blender Version
Broken: hash 5693337
Worked: unknown

Short description of error
In certain cases, subdividing two edges at once can create an invalid face, even though they are cleanly separated and are attached to valid geometry. That case appears to be when there's an Ngon and both edges border it.

Exact steps for others to reproduce the error
Open the .blend file and subdivide what is selected

.blend

Details

Type
Bug

Event Timeline

Adam Friesen (ace_dragon) set Type to Bug.
Adam Friesen (ace_dragon) updated the task description. (Show Details)
Adam Friesen (ace_dragon) created this task.
Adam Friesen (ace_dragon) renamed this task from The subdivision of two edges at once creates zero-area faces in certain situations to The subdivision of two edges at once creates an invalid face in certain situations.
Adam Friesen (ace_dragon) raised the priority of this task from to Needs Triage by Developer.
Campbell Barton (campbellbarton) closed this task as Invalid.

Currently this isnt considered a bug. At least the code is working as-intended (where faces are split irrespective of shape).

However I think it would be good to have the option to do an edge-only subdivide (without splitting faces).