Page MenuHome

Blender gives error message after closing user preferences
Closed, ResolvedPublic

Description

System Information
Windows 8.0
Intel HD 4600

Blender Version
Broken: Master

Short description of error
Blender gives the following error message in CMD after closing user preferences"
<!> event has invalid window

Exact steps for others to reproduce the error
Open user preferences then close

Event Timeline

Aaron Carlisle (Blendify) raised the priority of this task from to Needs Triage by Developer.
Aaron Carlisle (Blendify) updated the task description. (Show Details)
Aaron Carlisle (Blendify) set Type to Bug.

To addon this happens after closing any second window

Sergey Sharybin (sergey) closed this task as Archived.Nov 18 2015, 8:27 AM
Sergey Sharybin (sergey) claimed this task.

This isn't really a bug, just some event is being passed to the window which was closed and ignored. Surely would be nice if it doesn't happen, but it's also something where OS itself could do some insanity.

So thanks for the report, but it's not a bug.

Julian Eisel (Severin) reopened this task as Open.Dec 23 2015, 9:04 PM

Note: I'm not able to recreate this on Linux, so I guess this is an OS related issue (see T47048).

Strictly speaking, this is not a bug, agree. However, we also shouldn't print such info if it's not needed and everything works as intended. So, will open as bug with low prio and assign to myself for investigation. Need to launch my super slow Win machine and go through the pain of updating my build first time for months, so if anyone else feels like investigating: Feel free ;)

Julian Eisel (Severin) lowered the priority of this task from Needs Triage by Developer to Confirmed, Low.

In case it helps a bit, the file where this message gets triggered is the wm_windows.c file , Line 784 in the static int ghost_event_proc class.

Path: blender\source\blender\windowmanager\intern\wm_window.c