Page MenuHome

Blender crashes in editor preview mode, but not in rendering
Closed, ArchivedPublic

Description

System Information
Windows 10, Nividea 630M.

Blender Version
Broken: 2.76 dde4fc6
I now think this never worked.

Short description of error
Using the demo Barcelona blend file.
Set my render engine to GPU
And then turning on render preview in edit mode, then Blender Crashes with a TDR has been detected.
Meaning an Error that the GPU timeouts on responding back to the system.

Strangely though .. rendering the scene F12 (that's not the preview mode), works fine.
Also if i Enable progressive render mode to do a final render it works fine too.
I thought not all effects are in preview mode, so it should render render more lightweight, but apparently its not.
I'm suggesting maybe its an idea to have preview mode work in tile chunks too, or in a progressive like mode.

I think the crashing happens not upon uploading the model to the GPU, from the looks of it, 1 preview cycle is rendered (but even with setting preview to 1) it still crashes.

Exact steps for others to reproduce the error
Simple barcelona-paviloen demo scene, and a low end graphics card,

notes
(1) i first thought this never happened in older versions, but i was wrong, my own project simply got bigger
(2) This is not something critical to me, i dont depend on it, workaround is to use CPU i7 for larger blend files.

(who with latest updates seams to speed beat gpu again)
(they're speed is about roughly the same, depends on build).

Details

Type
Bug

Event Timeline

Peter Boos (PGTART) set Type to Bug.
Peter Boos (PGTART) created this task.
Peter Boos (PGTART) raised the priority of this task from to Needs Triage by Developer.

Will let Cycles guys decide, but pretty sure it’s no bug here, 630m is not really suited for GPU rendering anyway…

Well it has no problem to do the BMW speed tests
And lots of other work i do too, but yes i know cannt update the gpu of a laptop and its not the fastest gpu
Depending on blender build, the 630M can outperform the laptop octocore i7 2.3Ghz
if the drawing of the edit viewport where to be handled as suggested it might work .

Sergey Sharybin (sergey) closed this task as Archived.Dec 14 2015, 5:56 PM

This is just an additional timeout which Windows puts onto the GPU driver -- it has to give control back to the system in some specified timelimit. The reasons why this is happening for the viewport only are:

  • Viewport uses dynamic BVH which is slower to traverse
  • Tile size for the viewport is fixed and likely bigger than for the final render
  • Viewport will do some extra OpenGL stuff like, which could stress timings a bit more than final render.

Thing is, you'll tun into such timeouts sooner than later with a complex enough scene so would not really consider this a bug. The following link might help you https://blender.org/manual/render/cycles/gpu_rendering.html#the-nvidia-opengl-driver-lost-connection-with-the-display-driver

Would not really consider this a bug, it's just some specifics of how GPU compute works. Thanks for the report anyway.