Page MenuHome

Add Esc key to a tool not directly possible. But indirect it's possible.
Closed, InvalidPublic

Description

System Information
Operating system and graphics card

Win 7 64 Bit
Nvidia 760 GTX

Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen)
Worked: (optional)

Short description of error

You cannot directly assign the Esc key to a tool int the RMB menu of it. But indirectly it's possible.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Case: object mode needs a hotkey that doesn't conflict with the Text. When you enter the edit mode for a text, then the keys gets interpreted as letters, and not as hotkeys. So the imho most logical hotkey to go back to Object mode would be the Esc key, which is not treaten as a letter.

Problem: you cannot directly assign the Esc key in its RMB menu. You cannot change it to Esc in the input manager directly neither. The Esc key is simply not assigned. Esc cancels the assigning it seems. (funny part, sometimes it DOES assign the Esc key in the input manager directly, but very random)

Anyways. I found out that it is indirectly possible in the input manager by a new created node. Question here is, is it wanted that the Esc key cannot be assigned to tools? Then the indirect way should also be impossible (and of course also that it randomly works). Or should it be possible to assign the Esc key also to tools? One thing seems to be wrong here.

Steps for the indirect way:

create a hotkey for let's say object mode.
In Input manager create a new node.
Assign Esc key.
Then paste over the object.mode_set name
Change Mode to Object so that not all keys have the esc key assigned.

Voila, Object mode has now the Esc key assigned.

Details

Type
Bug

Event Timeline

Reiner Prokein (tiles) updated the task description. (Show Details)
Reiner Prokein (tiles) raised the priority of this task from to Needs Triage by Developer.
Reiner Prokein (tiles) set Type to Bug.
Julian Eisel (Severin) triaged this task as Needs Information from User priority.Dec 22 2015, 9:56 PM

This is a known issue and I don't see a good way to solve it. The Esc key is the only way to cancel the key input. However, it should be possible to assign the key using the text button within the box, not in its header:

This might be experienced as random, if you unconsciously switch between the buttons (since the buttons are pretty similar, the human brain tends to ignore the fact that they're at two different places and mixes them up).
Can you confirm this behavior?

Ah, indeed. That was most probably the "randomness" i have experienced. Thanks for the hint. Just curious, why are there two edit boxes at all? Looks a bit like double functionality :)

Too fast at the send button ...

Regarding the cancel action, why do you want to cancel a user input for assigning a hotkey at all? Imho when the key is wrong assigned, then you can simply change it again until it is right.

Julian Eisel (Severin) closed this task as Invalid.Dec 23 2015, 2:14 PM
Julian Eisel (Severin) claimed this task.

The button in the box header allows entering the entire shortcut (from mouse, keyboard or whatever), the button in the box is only visible for keyboard Map Type and is only for entering the keyboard key. This could be solved in a nicer way, but the input editor UI needs to be reworked anyway.

Re input cancelling - Do we want users to remember which key it was set to before? Instead a user should just always be able to exit the operation and reset the initial value (that's how it always works in Blender).


Closing as everything works as expected from code side.