Page MenuHome

generated navmesh has manifolds/overlapping triangles
Closed, InvalidPublic

Description

System Information
Mac OS 10.11.2, iMac 27-inch, Mid 2011

Blender Version
Broken: 2..76b f337fea

Short description of error
The generated navigation meshes may contain manifolds, loose edges or overlapping triangles

Exact steps for others to reproduce the error

  • created empty scene, erased the cube
  • added a plane
  • added a cylinder (removed top/bottom face)
  • duplicated it, placed aside to the first cylinder
  • both cylinders intersect with the floor
  • switching to "Blender Game" and
  • generated a navmesh in scene properties menu

the attached scene shows just a single misplaced triangle. in more complex scenes you get easily many of these errors

Details

Type
Bug

Event Timeline

Daniel Balster (dbalster) set Type to Bug.
Daniel Balster (dbalster) created this task.
Daniel Balster (dbalster) raised the priority of this task from to Needs Triage by Developer.
Sergey Sharybin (sergey) triaged this task as Needs Information from User priority.

I don't see the attached file. Please make sure simple demonstration file is attached, otherwise it's a bit tricky to follow your instructions and see the issue.

Bastien Montagne (mont29) closed this task as Invalid.
Bastien Montagne (mont29) claimed this task.

No news since one week…