Page MenuHome

Box Select - Face Select inconsistent under Occlude Geometry
Closed, ArchivedPublic

Description

System Information
Win 7 Ult 64
GeForce GTX 580

Blender Version
Broken: Always
Worked: Never

Short description of error
I'm aware this is another one that is borderline bug/incomplete feature. Anyway, I'm reporting it to bring to your attention.

In EditMode > Face SubComponent > Box Select
Occlude Geometry = True . Faces are selected that the selectBox includes.
Occlude Geometry = False . Only Faces whos faceCenters are included with the selectBox are selected.

Added image to illustrate this.
http://edge-loop.com/images/blender/bugtracker/FaceSelect_OccludeGeo.jpg

Is it possible to add an option to the Box Select that would reside in the Input Editor? A check box: Select by Face Center perhaps. In turn Both Occlude Geometry Modes would be consistent with selections giving the user an option to choose the preference which of the 2 face select behaviors to have.

Thanks.

Exact steps for others to reproduce the error
Described above

Details

Type
Design

Event Timeline

0rAngE (undo) raised the priority of this task from to Needs Triage by Developer.
0rAngE (undo) updated the task description. (Show Details)
0rAngE (undo) added a project: BF Blender.
0rAngE (undo) set Type to Bug.
0rAngE (undo) added a subscriber: 0rAngE (undo).
Campbell Barton (campbellbarton) closed this task as Archived.EditedDec 27 2015, 5:05 AM

@0rAngE (undo), this is not borderline, the feature is working as intended, further this is reporting a feature request as a bug, which is a mis-use of the tracker.

This is more a design task - so first find a developer who is interested to work on this and agree on how it should work exactly.

Bottom line: Its not much use to keep many tickets open for tasks nobody plans to work on.


So mail bf-funboard / bf-modeling with suggestions, discuss wider implications (how to manage options for each tool, maybe extend options panel... should this apply to circle-select, lasso too?... etc).

Its possible this could be default behavior, we don't necessarily need to add options, but good to get feedback from other modelers on this.

Noted.

This report was actually initiated by other modelers bringing this issue to my attention. Initially it was reported as a bug in my custom setup. After further testing and confirmation from other modelers, across different configs, it was confirmed that it's not my setup, but actually the way it's implemented in Blender, so I decided to file a bug report.

I wasn't aware of the blender mailing list (http://lists.blender.org/mailman/listinfo/)

Anyway, I'll make a proposal breakdown, for the mailing list, and see if I can summon some experienced modelers to corroborate this point of view.