Page MenuHome

Poor anti-aliasing when reducing size of image in the node editor
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card

Blender Version
Broken: 2.76

Short description of error
When reducing the image size, picture quality in sequencer much better than in node editor

Test files:


Exact steps for others to reproduce the error

  1. In file open sequencer open test image. Set size of render 10%. Note the quality of anti-alased result
  2. in node editor try to resize image using scale or transform node. Note, that the quality of anti-alasing worse

Details

Type
Bug

Event Timeline

Michael Soluyanov (crantisz) created this task.
Michael Soluyanov (crantisz) raised the priority of this task from to Needs Triage by Developer.

I can't edit description, why?

Sergey Sharybin (sergey) closed this task as Archived.
Sergey Sharybin (sergey) claimed this task.

This is a known limitation of the new compositor system which operates on the pixel level. Doing downsampling in such design is note possible with a nice antializas. There's no easy solution for this problem and hopefully @Jeroen Bakker (jbakker) will address it in his current project.

Thanks for the report, but it's not currently considered a bug.

P.S. You can't edit description because currently in Phabricator it's not possible to grant edit role to the author, meaning either you can't edit own tasks or you can edit everyone's tasks. This will be addressed at some point in the future.