Page MenuHome

3D view Display - bug with AO
Closed, ArchivedPublic

Description

System Information
Linux Mint 17.2 Rafaella Bi-Quad Intel 2.66Ghz x64Bytes - Nvidia OpenGL GT 630 4Go-vram

Blender Version
Broken: version 2.76 (sub 0), branch b'master', commit date b'2015-11-03' b'10:56', hash b'f337fea', b'RelWithDebInfo'
build date: b'2015-11-22', b'13:21:31' platform: b'Linux'

Short description of error
I have a Nvidia graphic card Asus GT630 4 Go Vram and I uploaded my nvidia driver with the new recommended official 352.79 release and CUDA 7.5 last development release. And not problem, when I use the GPU calculations, all is ok!

BUT here is the screen capture:
http://i.imgur.com/tJ1AQox.png

I see this horrible moire, even in edit mode.
I have a IIyama Prolite GE2488HS 1920 x 1080 60Hz so a good screen!
What is the problem, please?
http://i.imgur.com/OpDffHJ.png
I have tried :

  • multiple sampling ....
  • anisotropic filters
  • display methods

but not solutions!

Thanks in advance for all answers.
Spirou4D

Exact steps for others to reproduce the error

Details

Type
Bug

Event Timeline

Patrick Depoix (spirou4d) updated the task description. (Show Details)
Patrick Depoix (spirou4d) raised the priority of this task from to Needs Triage by Developer.
Patrick Depoix (spirou4d) set Type to Bug.

I have found why: When you are in 3D view and AO is standart activated !
Strenght 1.000
Distance 0.2
fallof 1.000
sampling 0.2

But very weird on my graphic card ? is it normal?

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.Feb 5 2016, 2:36 PM

This looks like OpenGL/shader bug, but please always attach a simple .blend file to reproduce the issue.

@Brecht Van Lommel (brecht), @Mike Erwin (merwin), ideas?

Bastien Montagne (mont29) renamed this task from 3D view Display to 3D view Display - bug with AO.Feb 5 2016, 2:37 PM

Are you sure about the 0.2 samples? Mine only allows 1, 2, 3 and so on.

I remember having those issues with an AMD 760 G integrated card. It would make moire patterns too. On the other side, a R7 360 works fine.

It's probably caused by different implementations of dfdx/dfdy functions. You might be able to get rid of some of those by introducing some more bias to the AO effect, but you'll have to test it on the GPU with the issue to make sure it works.

Check line 78 in

https://developer.blender.org/diffusion/B/browse/master/source/blender/gpu/shaders/gpu_shader_fx_ssao_frag.glsl

As always for best results we would need a render target to store screen space normals.

Ok thanks all for your return...I was sick and in bed!
Hello Antony! Thanks for your explanations !
My compile of Blender is made by Thomas Schiex, my friends with his ppa, i don't know what codes he use to compile his release.
I will speak with him about....

But when I desactive AO in 3D view all is ok. May be as said Mike Erwin, my setup is too strong.
But is t not important for me I desactivate to work. it's not inrender mode! All is good.

I wishe you a good happy New Year 2016 of Blend!
Thanks yet.
Patrick D as Spirou4D

Antony ,
Here my default blend for Bastien Montagne (mont29)
Playing with options of AO , I find that it's the distance option: the manager of this effect.
WIth 2 and + : no problem.
But 0 to 2 : this zebra effect!

Byebye
Patrick

Bastien Montagne (mont29) closed this task as Archived.Feb 19 2016, 3:23 PM
Bastien Montagne (mont29) claimed this task.

OK, this this looks like a known limitation for now, not really a bug. thanks for the report anyway. :)