Page MenuHome

Pointiness bake artifact when using selected to active
Open, Confirmed, MediumPublic

Description

System Information
Windows 7 64-bit
Radeon R9 270x

Blender Version
Broken: Both official 2.76b and latest build 2.76.10 f77110e
Worked: -

Short description of error
Bake result produce checker artifacts if trying to bake pointiness with subdivision surface and selected to active on.

Exact steps for others to reproduce the error
I use two meshes, one is high poly mesh using subdivision surface modifier and one aren't. I'm trying to bake pointiness of the higher poly to lower poly mesh. I use emission bsdf with pointiness color as input on high poly mesh to render pointiness color only.
I provide the blend file. Just hit bake and see baked result with checker artifacts. It still produce artifacts whether I'm using GPU or CPU render.

Blend file:

Viewport screenshot:

UV/Image Editor screenshot:

Details

Type
Bug

Event Timeline

Yusuf Umar (ucupumar) set Type to Bug.
Yusuf Umar (ucupumar) created this task.
Yusuf Umar (ucupumar) raised the priority of this task from to Needs Triage by Developer.
Brecht Van Lommel (brecht) raised the priority of this task from Normal to Confirmed, Medium.

Hello,
I have a similar problem, the results of the bake are quite different of the render ones.
I want to highlight some edges for a cartoon looking material, but some edges appear as a discontinue line instead of a nice highlight line like in the render...

here a image : http://www.lluc3d.com/clients/blender_bugREport.jpg

My Pc: Intel i5 6600K CPU, 16GB ram, windows 10 64bits, ATi Radeon HD 4800.