Page MenuHome

Boolean modifier is missing the "Use BMesh" option.
Closed, InvalidPublic

Description

System Information
Operating system and graphics card

Windows 7 64Bit
GeForce GTX 780

Blender Version
Broken: 2.76.11 2ecd67e
Worked: 2.76.5 296d125

Short description of error
When adding a boolean modifier, the recently added option "Use BMesh" is gone.

Exact steps for others to reproduce the error
In the default startup scene, select the cube and add a Boolean modifier to it. As you can see, the "Use BMesh" option is not present. Adding a second object for a proper boolean operation doesn't change this.

Details

Type
Bug

Event Timeline

Marius Eugen Mihai (mem) set Type to Bug.
Marius Eugen Mihai (mem) created this task.
Marius Eugen Mihai (mem) raised the priority of this task from to Needs Triage by Developer.
Campbell Barton (campbellbarton) closed this task as Invalid.

It was intentionally disabled since its not ready for 2.77 release.
(will enable after)

B (bnzs) added a subscriber: B (bnzs).EditedMar 19 2016, 8:54 PM

hi Campbell Barton. you wrote (will enable after) that after the release 2.77 you turn on "Use BMesh" again for boolean modifier in daily builds (as i understood)- if it possible - please enable it.

hi Campbell Barton. you wrote (will enable after) that after the release 2.77 you turn on "Use BMesh" again for boolean modifier in daily builds (as i understood)- if it possible - please enable it.

I join @B (bnzs) request! May you enable Bmesh on Boolean modifier?

Even if it's still under development and there are some "bugs" here and there, bmesh boolean is a lot faster than carve boolean; using them on many meshes are great time saver.