Page MenuHome

AO broken with GPU-Rendering and Branched Path Tracing
Closed, DuplicatePublic

Description

Win 7 64
GTX 750TI
GPU-Rendering

New Build (broken):
Hash:e24323e
18.02.2016

Old Build:
Hash:5af103f
14.01.2016

In the New Build (Branched Path Tracing):
GPU:
From a value of 8, the increase of the Samples has no longer any effect on the image quality.
Pattern change from Sobol to Correlated Multi-Jitter brings nothing.

CPU:
Works fine

Path Tracing works fine with CPU and GPU.

Testfile BMW1M-MikePan_AO
http://www.pasteall.org/blend/40515

New Build - GPU - Branched Path Tracing

Old Build - GPU - Branched Path Tracing

Details

Type
Bug

Event Timeline

Hans Nolte (ditos) updated the task description. (Show Details)
Hans Nolte (ditos) raised the priority of this task from to Needs Triage by Developer.
Hans Nolte (ditos) added a project: BF Blender.
Hans Nolte (ditos) set Type to Bug.

There was some fixes for BPT today and yesterday so cant reproduce with e24323e from today.
Git pull or use latest buildbot. :)

Cheers, mib

Hi Wolfgang,

see my description.

I use the latest buildbot (Hash: e24323e).

In this file the issue is actually with the mesh light samples, the AO samples work fine. That makes more sense since then it's the same code that fails in T47213.

Yes, great work Brecht!!!

Everything works fine in Build 3c4f971 (19.02.2016).

Massive speed improvement and a little more Vram consumption.

My Testscene went down from 01:38:58 (Build 5af103f) to 01:28:16 (Build 3c4f971).
(So, the report from here has also done. https://developer.blender.org/T47362 )

Vram consumption increases from 965MB to 1018MB.

Also the Testscene from here works https://developer.blender.org/T47213 with the New Build but without speed improvements.

Many thanks
Hans