Page MenuHome

Cycles lamp - different results in 2.76b and current master - IES lights compatibility issues
Closed, ArchivedPublic

Description

System Information
Win10 64bit, i7-5820K, 2xGTX970

Blender Version
Broken: 2.76 e24323e, 2.76b official
Worked: ----

Short description of error
I use the IES2Cycles addon to generate node tree for lamps but this addon does not work correctly with the newest Blender build from buildbot. I tried to generate the nodes in the 2.76b Blender and than open it in the buildbot blender but there were some other problems - the intensity of the lamp changed to negative values (black spots in the scene).

Exact steps for others to reproduce the error


1.) Open the file in the buildbot Blender and switch to rendered view - you can see a bright spot on the ceiling but the ceiling should be dark.
2.) Open the file in the 276b official, switch to rendered view and the the lamp shines correctly.
3.) Save the file in the 276b official and open it in the buildbot version. Switch to rendered view and you see a black spot on the ceiling.
4.) Save the file in the buildbot version and open it in the 276b official. Switch to rendered and the whole scene is completely black.

Details

Type
Bug

Related Objects

Event Timeline

Marek Moravec (marek) set Type to Bug.
Marek Moravec (marek) created this task.
Marek Moravec (marek) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) closed this task as Invalid.
Bastien Montagne (mont29) claimed this task.

Please do not report bugs about third-party add-ons not distributed with Blender, those shall be reported to the add-on's author(s).

This is not (only) a problem with the addon! The problem is that all the scene that have lamps that are generated with the addon are broken in the new buildbot Blender. You don't need the addon active to reproduce the bug.

Bastien Montagne (mont29) reopened this task as Open.

OK, can confirm differences in render between official 2.76b and current master, @Sergey Sharybin (sergey) should know whether this is expected or regression?

Bastien Montagne (mont29) renamed this task from IES lights compatibility issues to Cycles lamp - different results in 2.76b and current master - IES lights compatibility issues.
Bastien Montagne (mont29) triaged this task as Confirmed, Medium priority.

Think it's a regression, investigating.

Sergey Sharybin (sergey) closed this task as Archived.Feb 19 2016, 4:17 PM

So, while this is a regression, it's not Blender code which is responsible for this. It was caused by {{GitCommit|c81e6ff}} which allowed to have dynamic range for the vector curves widget. Unfortunately, we can't always make improvements without breaking forward compatibility, and sometimes scripters are to update the script to newer Blender versions.

This is now listed there: http://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.77/Cycles#Forward_compatibility

Please report the issue to an author of the script so he fixes it. Thanks for the report anyway.