Page MenuHome

Two tools, same tooltip. Eg. cut new topology for Knife and Select
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card

Windows 7 64 Bit, Nvidia 760 gtx

Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen)
Worked: (optional)

Short description of error

Some tools shows the same tooltips. Even when the functionality is different. In this case it is Knife and Select.

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Open Blender, enter edit mode, switch to the tools tab. In the Mesh Tools section hover over the Knife tool. Then over the Select tool.

The cause is that there is just one Knife tool, and just one Tooltip for it. Select is the very same Knife tool. But with another flag, which gives it another functionality. And this makes it another tool that deserves its own tooltip.

The label Select for the button suggests that there is something to select with. The tooltip tells you that it cuts new topology, like the knife too. But none of those two hints will really lead you to the conclusion that you first have to select a geometry, and that you can then cut this selected geometry only then.

There are more examples where there is the same tooltip for two different tools. Mark and clear seam for example.

Imho there should be one unique tooltip for one tool. And not a master tooltip for the parent functionality of the tool.

Details

Type
Bug

Event Timeline

Reiner Prokein (tiles) set Type to Bug.
Reiner Prokein (tiles) created this task.
Reiner Prokein (tiles) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) closed this task as Archived.
Bastien Montagne (mont29) claimed this task.

Thanks for the report, but this old known issue, not considered a bug currently.