Page MenuHome

Painting depth of field effect in viewport
Closed, ArchivedPublic

Description

System Information
Ubuntu 14.04 x86_64 Linux 3.16.0-30-generic

Blender Version
Broken: 2.77 RC2 6a593ab
Worked: 2.76b f337fea

Short description of error
If you will move the focus object behind it draws plume scene blur
https://youtu.be/XqA1BgKiE9M

Exact steps for others to reproduce the error

  1. Enable "Depth of Field" in viewport
  2. Switch to view from camera
  3. In "Depth of Field" section of Camera Settings select Focus object
  4. Move object in front of the camera and watch at the strange blur trail behind it.

Details

Type
Bug

Event Timeline

my369@yandex.ru (acvarium) updated the task description. (Show Details)
my369@yandex.ru (acvarium) raised the priority of this task from to Needs Triage by Developer.
Campbell Barton (campbellbarton) triaged this task as Needs Information from User priority.Feb 22 2016, 9:25 AM

Cant redo the error, can you confirm if this happens when grabbing the empty in this file

?

If not, please upload a blend file which can be used to reproduce the error.

Also, could you attach system info?
https://www.blender.org/manual/getting_started/help.html#save-system-info

I did some experiments with this file and the various versions of Blender since 2.74.
The problem turned out to be wider and more mysterious than I expected.
https://youtu.be/33IZRu1RP8Q
https://youtu.be/tEk8S2FMBlg
I understand that this is likely to blame for my video driver, but still hope that the solution will come from your side.
I have nvidia gtx 870m and use driver version 331.38, because so far I have less problems with it.

I understand that this is likely to blame for my video driver, but still hope that the solution will come from your side.

This isn't reasonable to expect, of course workarounds may be possible, but if this is a driver bug and developers can't redo. its unlikely we can work-around it.

Campbell Barton (campbellbarton) raised the priority of this task from Needs Information from User to Normal.Feb 25 2016, 11:07 PM
Aaron Carlisle (Blendify) closed this task as Archived.Apr 17 2017, 6:30 AM
Aaron Carlisle (Blendify) claimed this task.

Closing due to lack of activity.