Page MenuHome

point density texture bug
Closed, ArchivedPublic

Description

System Information
win 10

Blender Version
Broken: 2.77 (second official beta release)

Short description of error
Blender crashes with 2 density texture materials,
For a link of the file to test it with, and some graphical display see the two posts here:
http://www.blenderartists.org/forum/showthread.php?318765-Blender-2-7x-development-thread&p=3013211&viewfull=1#post3013211

Exact steps for others to reproduce the error
the problem start as soon as i connect both point density textures to the mix shader connect, (to get some cloud variation).
Tried a similar setup where i used color mix node also hangs blender. trying to render or in viewport switch to renderview crashes.

Details

Type
Bug

Event Timeline

Peter Boos (PGTART) set Type to Bug.
Peter Boos (PGTART) created this task.
Peter Boos (PGTART) raised the priority of this task from to Needs Triage by Developer.
Sergey Sharybin (sergey) triaged this task as Needs Information from User priority.

I can not reproduce the issue here by connecting the point density to a mix node and rendering.

Please do not send us to the forums, it takes forever to extract a reproduceable case from there and put all the information needed to reproduce the issue here in the bug tracker, including:

  • Simple .blend demonstrating the issue
  • Exact steps of how to reproduce the issue

it took me 2 secconds to copy if from BA


It seams that the below node setup (for making clouds) seams to crash blender, i was wondering if i am doing something that isnt supposed to be done, or if others can confirm that this node setup tends to crash blender 2.77 (sometimes not directly). crash in viewport and on rendering. sometimes not directly sometimes after a few secconds.

I placed a strong sun on top.
Made a flat ground surface from a cube divided randomized it a bit; then i put on a boid particle system on it.
Boids have the nice effect in that they flock together a bit. creating a dispersion distribution

Plased a large cube over it with and using cycles material with a single point density texture still doesn't seam crash blender.
The problems seam to start when i add another point density node using a different sphere size, and let a random node choose between the two point density shaders as in below. (the point density shaders use the same particle system)

The cloud.blend file is not the actual test case, please try to make it possible for us to reproduce the error next time.

Here is my attempt at reproducing the screenshot. I get an assertion failure (no idea if that is the actual error):

blender: /home/lukas/src/bf-blender/blender/intern/cycles/kernel/./kernel_jitter.h:40: int ccl::cmj_fast_div_pow2(int, int): Assertion `b > 1' failed.

Well i dont see any error, it freezes and then Windows notifies that blender is not responding and blender crashes.

I think i nailed it a bit more down now, here is a new blend file.
1st test : This file load and will render in viewport.
2ndtest : Its kinda weird because now i have it open for 30 minutes and nothing happened
3th test : seams to happen quickly when i alter the node group
4th test: while clicking on values of the musgrave or point density it happened.

And now i think i figured out why, if i enter some value, scale in musgrave or pointdensity size, a single click goes fine.
But now when i do clicker-di-click-click-click (fast clicking) to change a value, it then crashes, because the viewport cannt addept that fast to it, it seams

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Normal.
Sergey Sharybin (sergey) lowered the priority of this task from Normal to Needs Information from User.Mar 3 2016, 4:30 PM

Ooh, my reply didn't post for some reason and was kept in drafts..

I actually did couple of fixes in the area, so please grab latest build from https://builder.blender.org/download/ and see if the issue is resolved for you.

It seams to be solved now, maybe the nodes got a bit slower, but its ok.
slower in the sense of fast clicking on a value to change it.
Code seams to wait now till rendering is finished before accepting another value.
I guess side effect of some threading result of gui-update

Julian Eisel (Severin) closed this task as Archived.
Julian Eisel (Severin) claimed this task.

Closing now, since reported issue seems to be solved. I'm not sure if the delayed drawing is really supposed to happen though...