Page MenuHome

Video sequence editor: Changing audio pitch of cut audio strip changes audio play origin..
Closed, ArchivedPublic

Description

System Information
Windows 7 64bit
Intel i3 3240 3.40GHz
Nvidia GTX 750 Ti 2G
8GB DDR3 RAM

Blender Version
Blender 2.76b (also effects 2.76, and likely would be in 2.76a{F286039})

Short description of error
In the video sequence editor, if the pitch of an audio track of a cut strip is change to a value above 1, it will play fine the first time
it is heard through, but on the second time the audio will not start from the same place.. Instead it will start from later in the track
rather than from where the strip was cut..

Unfortunately i have found no work-around for this bug so as of now i am stuck and cannot edit videos the way i want using Blender :/

Exact steps for others to reproduce the error
This bug happens with any movie clip (or even just audio tracks alone)

Simply cut (hard) a clip so there are 3 parts (preferably evenly sized as it should be easy to tell the differences),
Now change the middle audio track so it's pitch is say.. 1.5 (As long as it's above 1.0 the bug will occur)
Play the animation until the middle strip is played all the way through, everything should be how it should..
Now play the animation a second time.. Notice the middle audio's origin is now later than before.. That's the bug..

The only way to reset the pitch's origin to where it was is to revert from a save prior or to undo until before the pitch change..

...

I have attached a .blend file with a start of a Blender tutorial from Blender Guru.. I have also added some subtitle-like additions
to it so it's easier to tell where the audio slides to..

Blend file:


Second link - Mediafire download for .blend: http://download949.mediafire.com/5q2942haa3fg/aus5lcpq2qh3joo/VIDEO+EDITING+BUG+-+Audio+strip+origin+pitch+bug+2.blend

Here is also a recording of myself replicating the bug in Blender, recorded using Bandicam:
https://www.youtube.com/watch?v=kmWs9qXxwzo&feature=youtu.be

...

Thank you for reading, replicating and/or watching, and i hope
that this bug/issue will be resolved for a future release :)

~AURAvulpes

Details

Type
Bug

Event Timeline

Travis Appleby (AURAvulpes) created this task.
Travis Appleby (AURAvulpes) raised the priority of this task from to Needs Triage by Developer.

Ignore the first link which appears after "and likely would be in 2.76a", That was the larger version of the file anyway.. (I can't edit the link out.. because lack of privileges..)
The second link references is the smaller file that's only 9MBs rather than the unnecessarily bloated 50MBs or so that the other one is..

Bastien Montagne (mont29) triaged this task as Normal priority.

Not totally sure we consider this a bug, @Joerg Mueller (nexyon)? @Sergey Sharybin (sergey)?

Thing is, pitch is simply reading audio quicker/slower, so it's same as with speed video effect, which does compensate for non-zero-starting strips, so think audio should follow same behavior…

I understand that the pitch does read the audio quicker and slower, but that's not really the issue I'm worried about..

It's just that if i were to make a video with changes in pitch for some strips in parts it will sound fine the first time i play
it, but if i edit more, the second time the audio strips (I already played) start playing again, their starting point is shifted
and the editing process for the project is kinda ruined.. :/

I don't see why the audio should be shifted from the point it was cut anyway..

The audio at the end of the strip doesn't matter, but if the start isn't
the same as it was when it was first heard, something's not right :/

First time "This time we're going to be tackling the world.. Now this is something that quite.."
Second time "the world.. Now this is something quite a few of you have been requesting for.."

This can not be as easily solved as you think it can be. The problem is that the pitch can be animated. A proper solution would be to somehow cache the start position in the sound for every frame. This is not done anywhere at the moment.

Alternatively we could just assume the pitch is constant and set the beginning of the sound accordingly when it is cut/seeked, but that solution is almost as problematic as the current one of not considering the pitch during seeking.

In any case this is more a missing feature rather than a bug.

Hmm.. I see.. o -o

How would i go about caching the audio's start position as a work around for now?
At least until (maybe) the missing feature is added at a later stage..

Or if this doesn't work is there any way of working around this?

I don't want to have to buy some other program to edit videos
when Blender works fine as an editor with the addition of being
able to easily composite scenes and stuff.. :/

The cache is already how it would be implemented in the code, it's not something you can just do in Blender.

How do you change the pitch? Is it animated? Do you change it for every cut part? What you could do is, when it is correct - render the audio and add this file.

What you could do is, when it is correct - render the audio and add this file.

Yes, that could work.. Though it'd be quite tedious..
Especially if it's a long animation.. it should still work fine..

Thank for the suggestion, i will try that ^-^

Travis, I found a workaround:

  • In the second time, pause the playback, select the pitched strip, enable and disable Mono sound option, and playback again.

Please, tell me if it works for you.

Sergey Sharybin (sergey) closed this task as Archived.Jul 29 2016, 1:55 PM
Sergey Sharybin (sergey) claimed this task.

@Joerg Mueller (nexyon), close as a TODO since you consider it a known design limitation. Not sure if you mentioned this in any of Audaspace TODO lists, but please feel free to mention this in Blender's TODO list [1].

[1] https://wiki.blender.org/index.php/Dev:Source/Development/Todo