Page MenuHome

Cycle is slowing down a lot with high def renders since Blender 2.68a in GPU _and_ CPU.
Closed, ArchivedPublic

Description

Cycle is slowing down a lot with high def renders since Blender 2.70 in CUDA/GPU _and_ CPU.
Reducing the size of the titles seems to help a bit... But it's not an ideal solution because of slow render time with small thead on GPU

I have done several test renders with this scene:


Blender 2.77 RC1 --> "Render Preset at 100% (10240*4320), tiles size 128*128, CUDA/GPU" --> estimated time 2h22 (to long to finish the render)
Blender 2.77 RC1 --> "Render Preset at 100% (10240*4320), tiles size 64*64, CUDA/GPU" --> estimated time 1h47 (to long to finish the render)
Blender 2.70a --> "Render Preset at 100% (10240*4320), tiles size 128*128, CUDA/GPU" --> estimated time 3h (to long to finish the render)
Blender 2.70a --> "Render Preset at 100% (10240*4320), tiles size 128*128, CPU" --> estimated time 2h (to long to finish the render)
Blender 2.68a --> "Render Preset at 100% (10240*4320), tiles size 64*64, CPU" --> render time 11m50s (2*Xeon 2660v3)
Blender 2.68a --> "Render Preset at 100% (10240*4320), tiles size 128*128, CUDA/GPU" --> render time 3m54s
Blender 2.68a --> "Render Preset at 100% (10240*4320), tiles size 400*400, CUDA/GPU" --> render time 2m51s

PC Configuration:
Windows 8.1
2x geforce Titan + geforce 780
CPU 5820k
64Gb ram

Details

Type
Bug

Event Timeline

Ronan Zeegers (ronan) added a project: Cycles.
Ronan Zeegers (ronan) set Type to Bug.
Ronan Zeegers (ronan) created this task.
Ronan Zeegers (ronan) raised the priority of this task from to Needs Triage by Developer.

Hi, I can render this scene in about 10 minutes on my system with Blender 2.77 RC1.

http://www.pasteall.org/pic/100045

Opensuse Tumbleweed x86_64
Intel i5 3570K
GTX 760 4 GB /Display card
GTX 670 2 GB
Driver 361.28
Intel opencl_runtime_15.1_x64_5.0.0.57

There was lately some reports about slowness on GTX 980Ti and Titan.

https://developer.blender.org/T45093

Read backwards, it is a long thread.

Sergey Sharybin (sergey) triaged this task as Needs Information from User priority.

That's quite a slowdown actually.. Things to do in order to help us understanding what's going on:

  • Load factory settings before rendering
  • Render from the command line
  • See if Image Draw Method in User Preferences -> System makes any difference (GLSL might be faster for you)

Hello Sergey,

Factory settings?
The Blender 2.68a, 2.70a and 2.77 RC1 comes from a fresh download on Bender.org (the zipped version without install)

I have switched the GLSL mode in the Preferences-->"Images Draw Method". It better but not has good has in Blender 2.68a:
Blender 2.68a (Image Draw Method, 2D Texture) --> Tiles 400x400 --> render time 3m10s
Blender 2.77 RC1 (Image Draw Method, GLSL) --> Tiles 400x400 --> render time 31m08s
Blender 2.77 RC1 (Image Draw Method, GLSL) --> Tiles 256x256 --> render time 21m46s

and with the command line (blender -b 10Ktest-BUGreport.blend -f 1) with the 2.77 RC1 version, Tiles 400x400, :
render time 35m39s

I don't know if this information can help you but I have this problem on 4 differents PC all with windows 8.1

You're comparing too many different things together, it's hard to follow that. Please limit the test case to:

  • CPU compute only
  • Tile size of 64x64
  • Resolution of 10240*4320

With such configuration please compare render times of different version from the command line and different window draw method.

Testing this .blend on OS X with a dual core CPU, for me the Scopes being visible in the image editor slow things down a lot. Try hiding those (T key) and see if it makes a difference.

Ok, I did some new renders on CPU.
Here are de results:

CPU - 2.68a - 2D Texture -- render time 12m13s
CPU - 2.68a - GLSL -- render time 11m55s
CPU - 2.70a - 2D Texture -- after 1h31m, estimated remaining 145h28m
CPU - 2.70a - GLSL -- after 34m19s, estimated remaining 2h19m
CPU - 2.70a - GLSL (without the Scopes / T key) -- render time 4h46m32s
CPU - 2.70a - Command line -- render time 12min01s

And the computer is a double Xeon 2660v3 with 128Gb under Windows 8.1

I've got idea that it's caused by rBc5d7ea0, but can't really verify yet because only developing on laptop for the time being.

Are you building blender yourself to test some patches?

Also, do you mind mind testing 2.69 (similar to how you testes 2.70a) ?

Long time ago, I did bluid my own blender from main tree with linux and windows.
But it was with svn and scons

So if you really really need it, I can take the time to learn to build Blender with the new tools ;)

a quick test with Blender 2.69

CPU - 2.69 - 2D Texture -- render time 12m06s
CPU - 2.69 - GLSL -- render time 12m08s

Seems 2.69 has nice and fast render speed, then the commit i've referenced above can't be a culptrit since it's in the 2.69 release. Back to the drawing board i guess..

Was testing the file on a more powerful desktop today and didn't see major difference between 2.68, 2.70 and current master. What i did is:

  • Got 10Ktest-BUGreport.blend from an original comment
  • Hide toolshelf in image editor, so no scopes are visible
  • Set compute device to CPU

Such configuration rendered the file in approx the same time for all builds i've mentioned above. Is this benchmark similar to what you've been doing?

Can we bring benchmark to a new level, by doing the following:

  • Run blender from the command line: blender.exe --factory-startup (to be sure we don't load any buggy addons at all)
  • Open file from original comment without loading UI (disable Load UI option)
  • Switch to CPU rendering

Strange.. I have this problem with different computers. Are you testing the file with Windows 7 or 8?

For my tests, I've downloaded the different Blender's' 2.xx from blender.org in zip format (no install), open "10Ktest-BUGreport.blend" and then render.
I didn't change the compute device to CPU because CUDA was not actived in the preferences.

I'll do the "blender.exe --factory-startup" + Load UI disabled tests later today with Blender 2.69 and 2.70a.

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Normal.

I actually tested both Linux and Windows 10. In both cases i can not confirm the slowdown with fresh installs of all blender versions. It is most likely something up to your specific setup.

The issue reported can't be reproduced so far, and has been moved to the BF Blender: Unconfirmed project.
If 2 other people aren't able to redo the bug after 2 weeks, it will be closed.

We appreciate the effort that goes into making bug reports, but to be able to fix bugs we have to be able to redo them.
If there is anything you can provide to help others to reproduce the problem, be sure to include it.

Ok Sergey, I'll try to do more tests.
I'm working a lot with really highres images and it's a very annoying bug for me...

I can reproduce this bug on 4 differents computers (all with multiple graphic cards and win 8.1)
have you tried on a computer with multiple nvidia cards?

It is not enough for you to reproduce the bug, you should teach us to reproduce the issue, otherwise we can not solve the issue.

For the CPU rendering amount of GPUs should not matter (and as was mentioned above you should limit test scenario to https://developer.blender.org/T47641#361766)

Make sure:

  • You're using factory startup (with no addons enabled)
  • You tested the file loaded with "Load UI" disabled
  • You tested render time on both UI rendering and command line rendering
Bastien Montagne (mont29) closed this task as Archived.Jun 2 2016, 12:19 PM
Bastien Montagne (mont29) claimed this task.

I’m sorry, but we cannot investigate an issue we cannot reproduce, so will archive this report until someone can give enough elements to consistently reproduce it. Thanks for the report anyway.