Page MenuHome

animation drivers on the "mute" property of a VSE strip appear not to work during render.
Closed, ResolvedPublic

Description

System Information
Linux bubastis 4.0.5-gentoo #1 SMP Mon Nov 16 11:48:34 EST 2015 x86_64 Intel(R) Core(TM) i7-4800MQ CPU @ 2.70GHz GenuineIntel GNU/Linux
01:00.0 VGA compatible controller: NVIDIA Corporation GK107GLM [Quadro K1100M] (rev a1)

Blender Version
Broken: 2.76b

Short description of error

I have a VSE strip with an animated "mute" property using fcurves. I set up a second VSE strip with a driver on its "mute" property to copy the value so I could animate it in one place instead of two or three. The driver works when I'm just jumping around the timeline in the blender UI. Unfortunately, if I render the animation, the driver does not work at all. The "mute" property on the strip with the driver stays the same as it was in the UI before I started the render.

Exact steps for others to reproduce the error

Create an image strip.
Rig it for Image Offset and rig the X and Y.
Add a couple of keyframes to change the value of the "mute" property (the eyeball icon)
Use the right-click menu on the eyeball to copy the data path of the mute property.
Create a second image strip covering the same time bounds.
Rig it for Image Offset and give it an X and Y that allow you to see the first and second image strips in different sections of the canvas.
Put a driver on the "mute" property of this second strip and set it to be the average of the Single Property of the Scene.
Paste the data path of the first strip's mute property.
Notice how the driver works just fine when you jump around in the timeline.
Unfortunately, if you do a render, the second strip does not animate its mute property correctly.

Details

Type
Bug

Event Timeline

Robert Forsman (mutantbob) created this task.
Robert Forsman (mutantbob) raised the priority of this task from to Needs Triage by Developer.

Since I do not have drag&drop, and this web site STILL lacks a traditional file upload form, I have uploaded my .blend file to http://www.pasteall.org/blend/40918

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

Adding the file here (note that you need to unpack the picture, packed images do not work in VSE)

From quick test it’s working in current master, please try the latest build from our buildbot.

Yeah, I wish there were a way to create an image strip from a packed image. That limitation has annoyed me twice in the past week.

Anyway, I downloaded the blender-2.77-9c8b6cc-glibc219-x86_64 and that version of blender appears to work as I wanted. It seems the bug in 2.76 has been fixed already and I hope it stays fixed when 2.77 is released.

Bastien Montagne (mont29) closed this task as Resolved.Mar 4 2016, 5:14 PM
Bastien Montagne (mont29) claimed this task.

Cool, then we can close it. :)