Page MenuHome

First or second frame messes up in movie clip editor.
Closed, ArchivedPublic

Description

System Information
Windows 10 Home
Processor: Intel(R) Core(TM) i5-3337U CPU @ 1.80GHz
RAM: 4.00GB
System: 64 bit

Blender Version
Broken: (2.77RC2 1e1118e, 2.76b f337fea, 2.62)
Worked: (optional)

Short description of error
After finishing the motion tracking, if I press shift left arrow to go back to the first frame, the frame messed up (to say it properly, the image is replaced with the image in a frame that I was there when I hit press shift left arrow)

Exact steps for others to reproduce the error
The same error can be seen in this tutorial from Blender Cloud at 14:20 (https://cloud.blender.org/p/track-ma...4a2a00ad6c65ef).
The tutor is fixing that by pressing "reload clip". I'm watching this video series and I can watch the error at least five times. The version the tutor is using is 2.62.

Now in 2.77, the bug still happens. In my case, this happens almost always. Possibly because of lack of RAW(4.00GB)? Memory cache limit in User Preferences is set to be 1024.

I hope this problem is fixed because this happening always isn't comfortable.

I don't know if I need to post the file and the video, because when you reload it, it will be fixed.


(80mb)

Details

Type
Bug

Event Timeline

Ricky (RickyIma) raised the priority of this task from to Needs Triage by Developer.
Ricky (RickyIma) updated the task description. (Show Details)
Ricky (RickyIma) added a project: BF Blender.
Ricky (RickyIma) set Type to Bug.
Ricky (RickyIma) added a subscriber: Ricky (RickyIma).
Ricky (RickyIma) added a comment.EditedMar 8 2016, 6:17 AM

Someone advised me to use proxy, and that helped.

However in other word, I don't think I can make a movie without proxy always, because the video in movie clip editor affects rendered images through node editor. When I used the original movie clip, the weird transition was happening in render.

Sergey Sharybin (sergey) closed this task as Archived.Mar 8 2016, 10:19 AM
Sergey Sharybin (sergey) claimed this task.

You should use timecode in this case. Root of the issue goes to the fact that without pre-built timecode it's not always possible to reliably navigate in the video stream, which leads to wrong frames being decoded when scrubbing.

Thanks for the report, but it's in TODO to build timecodes automatically.

This is still an issue.
It's been on the radar for a while it seems.
2012: T31215
2014: T35133
2015: T44675

The tutorials I've come across don't specifically mention why they go through the exercise of splitting a movie into a png series and I suspect many of them aren't aware of this reason.

I've submitted a patch to the documentation here, if someone wants to review/expand/re-word it: https://developer.blender.org/D6105
I'll look into a code solution when I have time. At the very least some kind of hint to the user to help them avoid hours of trial and error ;)