Page MenuHome

Selecting object crashes Blender 2.77 on Ubuntu 14.04
Closed, ArchivedPublic

Description

System Information
Ubuntu 14.04, Intel Graphics + Mesa DRI (3.0, 10.1.3)

Blender Version
Broken: 2.77 22a2853, 2.77 7f03e7c (both 64bit glibc211 and 64bit glibc219 from builder.blender.org)
Worked: 2.76b f337fea on Ubuntu 14.04, Blender 2.77 22a2853 on OSX

Short description of error
Right-clicking on object/mesh causes Blender to crash.

Exact steps for others to reproduce the error
With fresh install of Blender 2.77 on Linux machine and Blender factory defaults, selecting an object/mesh by right-click causes Blender to crash. Right-clicking on selected item to make active also causes crash. Further, Box Selection of object/mesh causes a crash, but Circle Selection has no problem.

All work without issue: selection of camera, light, empty, etc.; selection of verts, edges, and faces in Edit Mode; selecting the object in the Outliner.

Crash file:

Details

Type
Bug

Event Timeline

Jon Denning (gfxcoder) raised the priority of this task from to Needs Triage by Developer.
Jon Denning (gfxcoder) updated the task description. (Show Details)
Jon Denning (gfxcoder) set Type to Bug.
Julian Eisel (Severin) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Mar 20 2016, 9:25 PM

*/me rings Intel driver issue bell* ;) In most cases such issues can be solved as described here. Could you check this and report back if it solved your issue?

Changing User Prefs to use OpenGL Occlusion Queries does solve the selection problem in 2.77 for right-click selection and box selection. Thanks!

Since this seems like a typical Intel driver issue, is there a way to make "Automatic" use OpenGL Occlusion Queries with Intel cards? Or are there strong reasons to use to OpenGL Select with Automatic?

Julian Eisel (Severin) closed this task as Archived.Mar 20 2016, 9:49 PM
Julian Eisel (Severin) claimed this task.

I should've bet on that :) This is not the first report about such issues in 2.77 (all Intel IIRC), not sure what could cause it.
CCing @Brecht Van Lommel (brecht) and @Mike Erwin (merwin) - maybe they have an idea on what could cause this and how to solve.

Hey @Jon Denning (gfxcoder), check if upgrading your Mesa package resolves this. There was a bug in old Mesa which was exactly this (VBO + selection = crash) and fixed two years after we reported it :). I think it was sometime in 2014/2015 which is when your implementation came out, so there's a chance latest versions are fine.

Found the bug report:

https://bugs.freedesktop.org/show_bug.cgi?id=59455

Looks like it is indeed older than 2014. Please update your Mesa library

Updating Mesa library to 11.1.2 did fix the problem. I can now use either OpenGL Select or Automatic without Blender crashing, although it is noticeably slower than OpenGL Occlusion Queries. Thank you for all your help!