Page MenuHome

Mix Shader using Fresnel as Factor not displayed properly on the 3D viewport
Closed, ArchivedPublic

Description

System Information
Linux Mint 17.3 64-bit, NVIDIA GeForce GTX 550 Ti 2GB ()

Blender Version
Broken: 2.77 #22a2853


Worked: 2.76b #f337fea

Short description of error
When viewing a material shaded object on the 3D viewport, the result is strange and not the same as the rendered result.

Exact steps for others to reproduce the error

  1. Change engine to Cycles Render
  2. For any object, create a Mix Shader material (Diffuse BSDF with any color for both Shaders).
  3. As Factor for the Mix Shader, select "Fresnel" (NOT Layer Weight Fresnel, scroll down for the other option below).
  4. Change viewport shading to Material and compare with the rendered version.

Blend file:

Details

Type
Bug

Event Timeline

Ricardo Roehe (phoinx) raised the priority of this task from to Needs Triage by Developer.
Ricardo Roehe (phoinx) updated the task description. (Show Details)
Ricardo Roehe (phoinx) set Type to Bug.
Sergey Sharybin (sergey) closed this task as Archived.Mar 22 2016, 12:58 PM
Sergey Sharybin (sergey) claimed this task.

This issue was fixed after release branching and was not properly detected as a regression fix. This is one of the reasons of 'a' release which will happen in week-10 days. See http://lists.blender.org/pipermail/bf-committers/2016-March/047082.html

So thanks for the report, meanwhile you can use latest builds form builder.blender.org.

Nice! Thank you very much, Sergey!