Page MenuHome

"Persistent Images" breaks GPU freestyle rendering
Closed, ResolvedPublic

Description

System Information
Windows 10 64-bit
GeForce GTX 980

Blender Version
Broken: 2.77 22a2853
Worked: 2.76b

Short description of error
If rendering Freestyle on GPU while having "Persisten Images" active will make freestyle to either not display or display broken ( literally ).

Exact steps for others to reproduce the error

  1. Open Blender
  2. Change to Cycles ( dind't test on BI )
  3. Change device to GPU
  4. Enable freestyle
  5. Enable "Persisten Images" under Performance
  6. Render
  7. See how freestyle doesn't show up
  8. Either turn off Persisten Images OR change Device to CPU
  9. Now it works

Details

Type
Bug

Event Timeline

Victor (resourcev) added a project: BF Blender.
Victor (resourcev) set Type to Bug.
Victor (resourcev) created this task.
Victor (resourcev) raised the priority of this task from to Needs Triage by Developer.

Windows 7 Pro 64-bit
GeForce GTX 760

Works: Blender version: 2.77 22a2853

For what it is worth...

Freestyle worked correctly and as expected on my machine when I followed the steps in the bug report above.

Brecht Van Lommel (brecht) triaged this task as Needs Information from User priority.

I can't redo the problem either, testing on Windows 10 with a GTX 960, using the official Blender 2.77 release.

Can you try this with File > Load Factory Settings as the first step? Are there any addons influencing this? Can you attach a .blend file?

Here's a blend file

What I did:

  • Open it, load factory settings ( no additional addons ), change to Cycles, enable Freestyle, set device to GPU, enable Persistent Images under Performance, render.

Result:

  • Freestyle shows up broken.
  • I guess this is a problem of my own PC.
Brecht Van Lommel (brecht) raised the priority of this task from Needs Information from User to Normal.Mar 29 2016, 12:17 AM

Ok, thanks, it's quite odd that it just happens for you. I'll check the relevant code again to see if I can spot anything suspicious.

Sergey Sharybin (sergey) lowered the priority of this task from Normal to Needs Information from User.

Can not reproduce the issue on Windows 10 with GTX980Ti. Things to check:

  • Make sure you're using official NVidia driver (not the one from Windows Update but from nvidia.com)
  • Check if there are any errors printed to the console
Victor (resourcev) closed this task as Resolved.Apr 27 2016, 9:17 AM
Victor (resourcev) claimed this task.

After all I just installed the new nvidia drivers I was skipping ( because I thought they were just "game-ready" stuff ) and it got solved. So, my fault here.