Page MenuHome

subdivide bug
Closed, InvalidPublic

Description

System Information
amd, Windows 7 64bit, nvidia Geforce 7100 GS

Blender Version
Broken: 2.77, other users say also 2.76 and bellow...i did not test it myself
Worked: did not test in other versions

Short description of error
subdivide not working

Exact steps for others to reproduce the error

  1. start blender
  2. enter edit mode (for the cube)
  3. pick a vertex of the cube und move it up a little
  4. select one face, than subdivide
  5. select another face and than subdivide: it will not work.

Details

Type
Bug

Event Timeline

Gabriel (taxishop) added a project: BF Blender.
Gabriel (taxishop) set Type to Bug.
Gabriel (taxishop) created this task.
Gabriel (taxishop) claimed this task.
Gabriel (taxishop) raised the priority of this task from to Needs Triage by Developer.

Windows 7 Pro 64-bit
Nvidia GeForce GTX 760
8 gig ram

Broken: 2.75a, 2.76, 2.77

I tested using the steps described above and the subdivide is not working in all of the listed Blender releases.

I also tested using the attached file "bug1;blend". Again, no success in the various Blender releases.

hello Ignatz, that could be, i use to test releases of blender that way, with simple steps, it could be that also other releases have the bug.

i see now, the bug is even easier to reproduce, without moving the vertex:

  1. enter edit mode (for the cube)
  2. select one face, than subdivide
  3. select another face and than subdivide: it will not work.

It looks like Subdivide tool cannot properly subdivide ngons. For example, if you'll try to subdivide ngon cap of a cylinder, you won't be able to do it, instead it will only subdivide edges of that ngon. I've tested this in 2.76 and 2.77 and it looks like this behavior is identical in both versions.

I'm not sure, but it's possible that such behavior have a reason: Subdivide tool have specific rules on how to subdivide triangles and quads, but maybe there are no rules on how to subdivide a random ngon (especially with multiple iterations) so it only subdivide surrounding edges. If this is the case, maybe it would be useful to make Subdivision tool act like a Poke Faces tool in case of ngons (or something like that). Subdivision Surface modifier can subdivide ngons in multiple iterations into quads so maybe it would also be possible to have an option between "Poke Face" behavior and "Subdivide into quads" behavior. These are just my speculations, but still.

Bastien Montagne (mont29) closed this task as Invalid.

The ngon face is 'subdivided' (see how more verts are added to its edges), if you want actual face 'multiplication' you'll first have to triangulate ngons first… No bug here.