Page MenuHome

UV Editor, Pivot "Individual Origins" doesn't work as expected
Closed, ResolvedPublic

Description

System Information
Win7 64bit, Geforce 960

Blender Version
2.76

Short description of error
When I switch the pivot in UV Editor to "Individual Origins" UV Editing doesn't work any other then with pivot set to "Median".
To make it work as expected, I needed to "Edge Split" the entire mesh in 3D View temporarily.
Then I was able to scale UV faces around their individual centers, for example, like I expected it to work anyway, without having to realy splitting the entire mesh in 3D View Window first.

Strange somehow !
Or do I miss the meaning of this settings ?

Exact steps for others to reproduce the error
Add a plane and subdivide it in Edit Mode several times and UV unwrap it.
Go to UV Editor and switch the pivot to "Individual Origins".
It won't have any effect until you "Edge Split" the entire mesh into separate faces, in 3D View Window.

Event Timeline

martin me (martinme) set Type to Bug.
martin me (martinme) created this task.
martin me (martinme) raised the priority of this task from to Needs Triage by Developer.

looks indeed like code here [INDIVIDUAL_ORIGINS] was added specifically for UV islands (see rB0d3555).
While adding support for individual faces would be possible, I'm not sure how useful this would be? Could you explain a special usecase for this?

D1877 would at least clarify this a bit?

Bastien Montagne (mont29) claimed this task.

Yep, no bug here, it behaves the same as in mesh edit mode (if you select four connected faces, their 'individual' origin is shared median point of those four, same goes for UVs).

Note however that with UVs, you can choose to not select all UVs sharing same vertex/coordinate, which means you do can scale individual faces without deforming neighbor ones, at the cost of breaking UV-connection between them.

@Philipp Oeser (lichtwerk) indeed tip is bad here, will commit fix inspired from your patch, thx. ;)

@Bastien Montagne (mont29): note though that if you "choose not to select all UVs sharing the same vertex" [aka set Sticky Selection Mode to 'disabled'] and use individual origins it will still use the median point as center... this is just not implemented afaiks (code finds island centers). So the report has a point in that regard, I think (just not sure how useful it would really be)

martin me (martinme) reopened this task as Open.Mar 27 2016, 11:13 PM

I don't see any differnt behaviour in editing the UV, no matter if pivot set to "Median" or "Individual Origins".
Even doesn't matter what sticky mode is selected or whatever else I do.
Different from mesh editing in 3D View, in UV, pivot on "Individual" Origins" behaves the same like pivot on "Median".

If this is how it should work you can even delete UV pivot mode "Individual Origins" again, because then it got no meaningful function at all, as far as I can tell !

@martin me (martinme): individual origins works for separat UV islands (or individual faces in separat UV islands), it does make a difference there, so no point in removing the option...
But it doesnt work for faces in the same UV island, this might be unexpected, it could be implemented (maybe in the case that not all faces in an island are selected), but it is propably not considered a bug. Let others decide here...
Could you provid a practical usecase where this would really help? I could have a look then if desired...

I got it, it works on UV ilands.
Sorry for me being this stubborn.

For my individual problem I did found a solution already, as I mentioned in my initial posting.
I wanted to scale down all UV faces to zero around their individual centres, for some kind of uncommon usage.
This also works with "Individual Origins" on in UV Editor, but I needed to also Edge Split the entire mesh in 3D View to make it work in UV.

@martin me (martinme): you dont need to "edge split the entire mesh in 3D View" to create individual UV islands. You could e.g. grab a face in the UV editor (with Sticky Selection Mode disabled) and e.g move it off slightly (more than 0.0001) and voila: you have a new island... multiple ways to achieve what you want without leaving the UV editor...

Bastien Montagne (mont29) closed this task as Resolved.Mar 28 2016, 4:49 PM

Please do not reopen bugs yourself. And no bug here, feature requests etc. can go to ML.

Again I come to this problem.
Now I recogniced that, e.g. scaling around Individual Centres in UV Editor fails, even for UV Ilands, if the Mesh was unwrapped with "Project from View".
On the same Mesh, same UV settings, but unwrapped with "U -> Unwrap", it works fine.

And no, I don't would consider this a feature request ! I consider this a case of logical inconsistency !

@martin me (martinme): no reason to use exclamation marks (implies shouting...) we were listening, werent we? Reporting bugs is welcome btw. so thanx for this.
Anyways: I cannot reproduce your issue, I have no problem scaling individual islands produced by "Project From View". Are you sure you still have multiple UV Islands after projecting?
So: please provide a simple .blend then so we can reproduce the issue...