Page MenuHome

Blender 2.77 64bit linux crash when selecting object
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card
Linux mint 15
AMD radeon HD7670M

Blender Version
Broken: 2.77 hash 22a2853
Worked: 2.76b

Short description of error
When selecting ( right click ) an object in the 3d view, blender crashes.

This is the crash.txt

Blender 2.77 (sub 0), Commit date: 2016-03-18 12:34, Hash 22a2853

backtrace

./blender(BLI_system_backtrace+0x1d) [0x1aaa7ad]
./blender() [0x114146e]
/lib/x86_64-linux-gnu/libc.so.6(+0x370b0) [0x7fc66e7440b0]
/usr/lib/x86_64-linux-gnu/libdricore9.1.7.so.1(+0x166110) [0x7fc6603a6110]
/usr/lib/x86_64-linux-gnu/libdricore9.1.7.so.1(_tnl_run_pipeline+0x13d) [0x7fc6603a30cd]
/usr/lib/x86_64-linux-gnu/libdricore9.1.7.so.1(_tnl_draw_prims+0x5d8) [0x7fc6603a36d8]
/usr/lib/x86_64-linux-gnu/libdricore9.1.7.so.1(_tnl_vbo_draw_prims+0x6f) [0x7fc6603a423f]
/usr/lib/x86_64-linux-gnu/libdricore9.1.7.so.1(vbo_rebase_prims+0x1ba) [0x7fc660391b5a]
/usr/lib/x86_64-linux-gnu/libdricore9.1.7.so.1(_tnl_draw_prims+0x1b1) [0x7fc6603a32b1]
/usr/lib/x86_64-linux-gnu/dri/i965_dri.so(+0x2fa61) [0x7fc660d6aa61]
/usr/lib/x86_64-linux-gnu/libdricore9.1.7.so.1(+0x14dc9a) [0x7fc66038dc9a]
/usr/lib/x86_64-linux-gnu/libdricore9.1.7.so.1(+0x14eca4) [0x7fc66038eca4]
/usr/lib/x86_64-linux-gnu/libdricore9.1.7.so.1(+0x14f014) [0x7fc66038f014]
./blender() [0x175c92f]
./blender() [0x12373d8]
./blender() [0x123eb00]
./blender(draw_object+0x1848) [0x1245da8]
./blender() [0x122f271]
./blender(view3d_opengl_select+0x1ec) [0x12314ac]
./blender() [0x1228e6c]
./blender() [0x1229f1e]
./blender() [0x122a6c4]
./blender() [0x1149895]
./blender() [0x114ad4a]
./blender() [0x114b0d9]
./blender() [0x114b5a6]
./blender(wm_event_do_handlers+0x3be) [0x114babe]
./blender(WM_main+0x18) [0x1142d48]
./blender(main+0xefa) [0x10ea92a]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5) [0x7fc66e72eea5]
./blender() [0x113ff19]

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Right click any object in 3d view in attached .blend.

Details

Type
Bug

Event Timeline

Baptiste (Baptiste) raised the priority of this task from to Needs Triage by Developer.
Baptiste (Baptiste) updated the task description. (Show Details)
Baptiste (Baptiste) set Type to Bug.

Make sure, you use the latest and *official* AMD drivers from AMD.

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Apr 3 2016, 4:09 PM

/usr/lib/x86_64-linux-gnu/dri/i965_dri.so(+0x2fa61) [0x7fc660d6aa61], you have an intel CPU and are using its integrated GPU… Probably same old known intel bugs, you can try to change 'Selection Method' in blender's userpreferences, and also consider updating your mint version (15 is starting to be old afaik, they are at 17.3 now). And probably check how to actually enable your AMD GPU instead of Intel embedded one.

Julian Eisel (Severin) closed this task as Archived.EditedApr 3 2016, 5:06 PM
Julian Eisel (Severin) claimed this task.

A known issue caused by a bug in Mesa drivers (see T47860), updating Mesa package should fix it.
It has been reported many times in the last weeks (T47997, T47894, T47921, ....), so added a note in the release logs. In future reports we can simply link to it.

Closing as this appears to be a driver issue. We can reopen if updating driver doesn't work.