Page MenuHome

Smoke-cycles-OpenvVDB Adding velocity attribute crashes render
Closed, ResolvedPublic

Description

System Information
Operating system and graphics card

Blender Version
Broken: 673ddd4

Short description of error
Set that atribute and crash on render

Exact steps for others to reproduce the error
1-


2-try render (it should crash)
3-open again
4-change velocity to color or density
5-render (now shouldn't crash on render)

Event Timeline

Nahuel Belich (belich) set Type to Bug.
Nahuel Belich (belich) created this task.
Nahuel Belich (belich) raised the priority of this task from to Needs Triage by Developer.
jack (burton) closed this task as Resolved.Apr 6 2016, 1:55 AM
jack (burton) claimed this task.
Kévin Dietrich (kevindietrich) reopened this task as Open.

@jack (burton), please avoid closing task at random with no explantation as to why you're closing this.

Kévin Dietrich (kevindietrich) triaged this task as Confirmed, Medium priority.Apr 6 2016, 7:20 AM

The crash is due to an arithmetic exception thrown in the image interpolation code:

Program received signal SIGFPE, Arithmetic exception.

0x00000000032b46d1 in wrap_periodic (width=0, x=-1, this=<optimized out>)
    at /home/kevin/src/blender-git/blender/intern/cycles/kernel/./kernel_compat_cpu.h:113
113			x %= width;

Now the things is that only 'color', 'heat' and 'density' attributes/fields are supported in Cycles, but for some reason the 'velocity' attribute is still added and it crashes due to uninitialized data (would expect to have a nice pink/magenta volume instead, as for missing textures or images).