Transformation constraint inconsistent behavior (scale)
Closed, ArchivedPublic

Description

Blender Version
Possibly all versions?

Short description of error
While working on a project, I discovered an inconsistent behavior in the transformation constraint.

Because drivers have no way of referencing "self" value (as done in After Effects expressions, which is a needed feature, in my opinion) I found myself using the transformation constraint a lot to be able to manually alter a transformation parameter (location/rotation) beyond a driven value.

But that's the thing: I can have control of location and rotation, but not scale. As soon as the scale parameter is set, it's locked unlike location and rotation.

I'm not entirely sure if this would be more akin to a design flaw than a bug, but I thought I'd report just in case (couldn't find a discussion of this anywhere).

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Details

Type
Bug
Sergey Sharybin (sergey) triaged this task as "Incomplete" priority.Apr 13 2016, 1:33 PM

That is really hard to tell if issue you're encountering is a bug or not. Please always attach .blend file which demonstrates the issue you've got.

Currently it's sounds more like a limitation of a constraint which is not really considered a bug.

I'll do you one better than a .blend. Show and tell:

I think that should clearly convey what behavior I was expecting vs. reality. As you can see, the location and rotation are still manually adjustable even when the transformation constraint is set, but scale isn't.
It seems to me the location/rotation function as relative numbers (which is great), but scale functions as absolute.

And I fear you're right about it being a limitation, but.. here's to hoping, haha.

Bastien Montagne (mont29) closed this task as "Archived".Apr 22 2016, 7:33 PM
Bastien Montagne (mont29) claimed this task.

Thanks for the report, but this is a known limitation (commented in code), which we cannot address currently because it would break many existing rigs, unfortunately…

I'm still bumping up against this problem. Are there plans to remedy this limitation in 2.8? Even if it breaks older rigs, I'd be glad to have this limitation removed going forward.