Page MenuHome

Mesh is displayed triangulated when Cycles viewport alpha is combined with transparent shader
Closed, ArchivedPublic

Description

System Information
Windows 10 64-bit, Nvidia gtx 570 (render), Nvidia gt 610 (display)

Blender Version
Broken: 2.77a, c0943ba (latest 64-bit build)
Worked: -

Short description of error

In Cycles, when the 'Viewport Alpha' in the material's 'Settings' panel is set to 'Alpha Blend', 'Alpha Sort' or 'Alpha Clip' and the material has a 'Transparent' node connected and 'Transparency' is checked in the Object's 'Display' tab and the viewport shading is 'Material', the selected object appears triangulated.

Unchecking the 'Transparency' setting on the Object's 'Display' tab returns the mesh back to normal.

Exact steps for others to reproduce the error

  1. Open
  2. Toggle 'Transparency' on and off in the Object's 'Display' panel.

Details

Type
Bug

Event Timeline

Ray Mairlot (madog) set Type to Bug.
Ray Mairlot (madog) created this task.
Ray Mairlot (madog) raised the priority of this task from to Needs Triage by Developer.
Sergey Sharybin (sergey) closed this task as Archived.May 3 2016, 5:48 PM

The issue here that current GLSL is tightly using BI's material settings, which are totally different from Cycles. It is fixable, but since viewport shading upgrade is planned i would rather avoid attempts to fix system which is gonna to be replaced.

So thanks for the report, but considering it a TODO for now.