Rendering bug with AMD cards.
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card
Graphics: Radeon R9 290
Operating System: Windows 10.

Blender Version
Broken: 2.76
Worked: 2.75

Short description of error
Rendering any scene, complex or not will cause the scene to have lines across the screen.


Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Details

Type
To Do
Sergey Sharybin (sergey) triaged this task as "Incomplete" priority.May 2 2016, 10:20 AM

Please test with latest release 2.77a and latest builds from builder.blender.org. Also make sure you're using latest AMD drivers (from their site, not the ones from Windows Update).

This comment was removed by Mauro Castaldi (kastaldi).

I confirm this is the same problem seen in https://developer.blender.org/T48028
Anyway the artifacts are still there running the daily build blender-2.77-568514c-win64.zip with R9 390 8 MB NITRO (latest AMD drivers 16.4.2) on Win 10 x64

Bastien Montagne (mont29) raised the priority of this task from "Incomplete" to "Normal".May 15 2016, 11:01 AM

Problem still appears using daily build blender-2.77-a83bc4f-win64.zip (15-05-2016) and AMD drivers ver. 16.5.2 with R9 390 8 MB NITRO on Win 10 x64.

This is a driver failure, and what's annoying is that recently released 16.6.1 does not fix the issue. Commenting out any 5 closures in bsdf_eval() makes kernel to work fine, but not sure if it's red herring or some avalanche type of issue which triggers compiler issue.

Such issues are up to drivers developers, who can bisect code and find which exact change in driver caused this.

Please submit the issue to AMD developers.

For the meantime considering this a TODO, since it's not a blender bug.

Sergey Sharybin (sergey) changed Type from Bug to To Do.Jun 7 2016, 3:52 PM
Aaron Carlisle (Blendify) lowered the priority of this task from "Normal" to "Incomplete".Apr 14 2017, 9:41 PM

Is this still an issue with a build from builder.blender.org?

Aaron Carlisle (Blendify) closed this task as "Archived".May 16 2017, 8:53 PM
Aaron Carlisle (Blendify) claimed this task.

Since last asking for information it has been 7 or more days, due to the policy of our bug tracker
we will have to archive the report until the requested information is given.